<!DOCTYPE html>
<html version="HTML+RDFa 1.0" xmlns:og="https://ogp.me/ns#" lang="en"
      data-site-id="40070"
      data-tmplt="????"
      data-site="77968"
      data-addr="10.16.88.242"
      data-time="2020-01-22T04:05:03-0800"
      data-env="production"
      data-debug="false"
      data-layout="desktop"
>
<head>
    <script type='text/javascript' src='//cdn.districtm.ca/merge/all.ib.hg.js'></script>
        
<script>var _sf_startpt = (new Date()).getTime();</script>

<meta charset="utf-8"><script type="text/javascript">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</script>
<meta name="description" content="Learn more about the 2020 Mercedes-Benz E Class with The Car Connection review. Find prices, release date, pictures, expert ratings, safety features, specs and price quotes." >

<meta property="fb:pages" content="14924137380" >
<meta property="fb:app_id" content="115451182597" >
<meta property="og:site_name" content="The Car Connection" >
<meta property="og:type" content="product" >
<meta property="og:url" content="https://www.thecarconnection.com/overview/mercedes-benz_e-class_2020" >
<meta property="og:image" content="https://images.hgmsites.net/hug/2020-mercedes-benz-e-class_100732317_h.jpg" >
<meta property="og:title" content="2020 Mercedes-Benz E Class Review, Ratings, Specs, Prices, and Photos" >
<meta property="og:description" content="Learn more about the 2020 Mercedes-Benz E Class with The Car Connection review. Find prices, release date, pictures, expert ratings, safety features, specs and price quotes." >
<meta name="google-site-verification" content="V9IWZvYSmqTqLJdvv4KM5yUbzswzQb6XFcrgJCq-dWM" >
<meta name="y_key" content="b76b577d4b8c8d6a" >
<meta name="msvalidate.01" content="980788190813CA06E1A755281D49D247" ><title>2020 Mercedes-Benz E Class Review, Ratings, Specs, Prices, and Photos - The Car Connection</title><script type="application/ld+json">
{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.thecarconnection.com/overview/mercedes-benz_e-class_2020","url":"https://www.thecarconnection.com/overview/mercedes-benz_e-class_2020","isPartOf":{"@type":"WebSite","@id":"https://www.thecarconnection.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.thecarconnection.com/new-cars","name":"New Cars"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.thecarconnection.com/make/new,mercedes-benz","name":"Mercedes-Benz"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.thecarconnection.com/cars/mercedes-benz_e-class","name":"E Class"}}]},"mainEntity":{"@type":"Car","@id":"https://www.thecarconnection.com/overview/mercedes-benz_e-class_2020#this","url":"https://www.thecarconnection.com/overview/mercedes-benz_e-class_2020","name":"2020 Mercedes-Benz E Class","brand":{"@type":"Brand","@id":"https://www.thecarconnection.com/make/new,mercedes-benz#this"},"model":"E Class","vehicleModelDate":2020,"fuelEfficiency":{"@type":"QuantitativeValue","minValue":15,"maxValue":32,"unitText":"mpg"},"offers":{"@type":"AggregateOffer","availability":"http://schema.org/InStock","lowPrice":54050,"highPrice":111750,"priceCurrency":"USD"},"image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/2020-mercedes-benz-e-class_100732317_l.jpg#this","url":"https://images.hgmsites.net/lrg/2020-mercedes-benz-e-class_100732317_l.jpg","caption":"2020 Mercedes-Benz E-Class","description":"","width":1024,"height":679,"uploadDate":"2020-01-20T05:23:11-0800"}}}
</script>
<script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
    (function(){
        function retrieve(n){
            var k='kx'+'internetbrands_'+n, ls=(function(){
                try {
                    return window.localStorage;
                } catch(e) {
                    return null;
                }
            })();
            if (ls) {
                return ls[k] || '';
            } else if (navigator.cookieEnabled) {
                var m = document.cookie.match(k+'=([^;]*)');
                return (m && unescape(m[1])) || '';
            } else {
                return '';
            }
        }
        Krux.user = retrieve('user');
        Krux.segments = retrieve('segs').split(',');
        var k=document.createElement('script');k.type='text/javascript';k.async=true;
        k.src='https://cdn.krxd.net/controltag/sh2lfhber.js';
        var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
    })();
</script>
<script async src="https://js-sec.indexww.com/ht/p/184397-109240026891666.js"></script>

<link href="https://feeds.feedburner.com/TheCarConnection-NewsAndBlogs" rel="alternate" type="application/rss+xml" title="The Car Connection News" >
<link href="https://feeds.feedburner.com/TheCarConnection-CarReviews" rel="alternate" type="application/rss+xml" title="The Car Connection Reviews" >
<link href="/js/hgm/pushnami/manifest.json" rel="manifest" >
<link href="https://www.thecarconnection.com/overview/mercedes-benz_e-class_2020" rel="canonical" >
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon" >
<link href="/css_cache/565223.css" media="all" rel="stylesheet" type="text/css" ><!--<script src="/js/hgm/performance.js"></script>-->

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js"></script>

<script src="https://cdn.optimizely.com/js/2803520120.js"></script>


<script type="text/javascript" src="/js_cache/565104.js"></script>
<script type="text/javascript" src="/js_cache/565224.js"></script><script src="/ad.min.js"></script>
<script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-218811-12', 'auto');
                    // Optimizely Universal Analytics Integration Code
            window.optimizely = window.optimizely || [];
            window.optimizely.push("activateUniversalAnalytics");
            // End Optimizely Code
                ga('set', 'dimension1', 'Desktop');
        ga('set', 'dimension3', typeof sadfq2v3raesxf2dxx3r2348 == 'undefined' ? 'Blocker Enabled' : 'No Blocker');

        ga('set', 'dimension4',  (typeof disabledPixel == 'undefined'  || disabledPixel == '') ? 'No Pixel Blocked' : disabledPixel + ' Blocked');
                    ga('send', 'pageview');
            
    var _gaq = _gaq || [];
    _gaq.push(
        ['_setAccount', 'UA-218811-1'],
        // FIXME This doesn't take preview flag into account which may affect isPageMobile() result
        ['_setCustomVar', 1, 'Template', 'Desktop', 3],
        ['_setCustomVar', 3, 'Blocker Enabled', typeof sadfq2v3raesxf2dxx3r2348 == 'undefined' ? 'Yes' : 'No', 3],
        ['_setCustomVar', 4, 'Disabled Pixel ', (typeof disabledPixel == 'undefined' || disabledPixel == '') ? 'None' : disabledPixel, 3],
                    ['_trackPageview' ]
            );
    (function() {
        var ga = document.createElement('script');
        ga.type = 'text/javascript';
        ga.async = true;
        // ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        ga.src = 'https://stats.g.doubleclick.net/dc.js';
        document.documentElement.firstChild.appendChild(ga);
    }());
</script>
<script>
    var axel = Math.random() + "";
    var ord = axel * 1000000000000000000;
</script>
<!--[if lt IE 9 ]>
<link rel="stylesheet" type="text/css" href="/css/ie7+.css"/>
<![endif]-->
<!-- Google Publisher Tags - TCC-992 -->
<script async src="https://confiant-integrations.global.ssl.fastly.net/cVCBi6sio0Kr78j5IZSJs1SQ8No/gpt_and_prebid/config.js"></script><script src="//internetbrands-d.openx.net/w/1.0/jstag?nc=2922-TheCarConnection"></script><script async src='https://confiant-integrations.global.ssl.fastly.net/cVCBi6sio0Kr78j5IZSJs1SQ8No/gpt_and_prebid/config.js'></script>
<!-- Start: GPT Async -->
<script>
    var gptadslots = [],
        apstagslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script><script>
    googletag.cmd.push(function() {
        gptadslots[0] = googletag.defineSlot('/2922/carconnection.tmus/YearMakeModelPage/300x250_top', [[300, 250]], 'ad-2')
            .setTargeting('kw', ["top"])
            .setTargeting('tile', [1])
            .setTargeting('sz', ["300x250"])
            .setTargeting('page', ["model-intro"])
            .setTargeting('make', ["mercedes-benz"])
            .setTargeting('model', ["e-class"])
            .setTargeting('year', ["2020"])
            .setTargeting('segment', ["Convertible","Coupe","Sedan","Wagon"])
            .setTargeting('variation', window.hgm_variation || '')
            .setCollapseEmptyDiv(true)
            .addService(googletag.pubads());

        gptadslots[1] = googletag.defineSlot('/2922/carconnection.tmus/YearMakeModelPage/300x250_bottom', [[300, 250]], 'ad-3')
            .setTargeting('kw', ["bottom"])
            .setTargeting('tile', [2])
            .setTargeting('sz', ["300x250"])
            .setTargeting('page', ["model-intro"])
            .setTargeting('make', ["mercedes-benz"])
            .setTargeting('model', ["e-class"])
            .setTargeting('year', ["2020"])
            .setTargeting('segment', ["Convertible","Coupe","Sedan","Wagon"])
            .setTargeting('variation', window.hgm_variation || '')
            .setCollapseEmptyDiv(true)
            .addService(googletag.pubads());

        gptadslots[2] = googletag.defineSlot('/2922/carconnection.tmus/YearMakeModelPage/728x90_top', [[728, 90]], 'ad-1')
            .setTargeting('kw', ["top"])
            .setTargeting('tile', [3])
            .setTargeting('sz', ["728x90"])
            .setTargeting('page', ["model-intro"])
            .setTargeting('make', ["mercedes-benz"])
            .setTargeting('model', ["e-class"])
            .setTargeting('year', ["2020"])
            .setTargeting('segment', ["Convertible","Coupe","Sedan","Wagon"])
            .setTargeting('variation', window.hgm_variation || '')
            .setCollapseEmptyDiv(true)
            .addService(googletag.pubads());

        $(function () {
            $('#ad-2').data('GoogleAdSlot', gptadslots[0]);
            $('#ad-3').data('GoogleAdSlot', gptadslots[1]);
            $('#ad-1').data('GoogleAdSlot', gptadslots[2]);
        });


        apstagslots[0] = {slotID:'ad-2',sizes:[[300, 250]],slotName:'/2922/carconnection.tmus/YearMakeModelPage/300x250_top_ad-2'};
        apstagslots[1] = {slotID:'ad-3',sizes:[[300, 250]],slotName:'/2922/carconnection.tmus/YearMakeModelPage/300x250_bottom_ad-3'};
        apstagslots[2] = {slotID:'ad-1',sizes:[[728, 90]],slotName:'/2922/carconnection.tmus/YearMakeModelPage/728x90_top_ad-1'};        googletag.pubads().enableAsyncRendering();
        googletag.pubads().collapseEmptyDivs();
        googletag.pubads().addEventListener('slotRenderEnded', function (event) {
                var slot = event.slot,
                    targeting = {},
                    status,
                    slotId = slot.getSlotElementId();               
                if (event.isEmpty) {
                    status = '- empty';
                    $("div[data-continues='" + slotId + "']").hide();
                }
                else {
                    status = '- line item ' + event.lineItemId;
                }
            if (window.isDebugMode) {    
                slot.getTargetingKeys().forEach(function (key) {
                    targeting[key] = slot.getTargeting(key).join(', ');
                });
                hgm.debug('gpt -', slotId, slot.getAdUnitPath(), status, targeting, event);
            }
        });
        if (window.Krux) {
            googletag.pubads().setTargeting('ksg', window.Krux.segments);
            googletag.pubads().setTargeting('kuid', window.Krux.user);
        }            googletag.pubads().disableInitialLoad();
            googletag.pubads().enableSingleRequest();        
        googletag.enableServices();
        hgm.debug('gpt - ready');
    }); // cmd push
</script>
<!-- End: GPT --><script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
    {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page  
    apstag.init({    
        pubID:'3188',    
        adServer:'googletag',    
        bidTimeout:2e3
    });

//apstag.debug('anable');

    // request the bids for the four googletag slots  
googletag.cmd.push(function() {
    apstag.fetchBids({    
        slots: apstagslots
    },function(bids){
        hgm.debug("apstag request for the apstag :", bids);
        // trigger the first request to DFP 
        googletag.cmd.push(function(){  
            apstag.setDisplayBids();        });
    });
});
</script></head>
<body>
    <script>
    // Google Tag Manager data
    dataLayer = [];
            dataLayer.push({"year_id":"30010581","year_seo_name":"2020","year_name":"2020","year":"2020","body_style":"2-doors","vcat":"2-doors","model_id":"20000468","model_seo_name":"e-class","model_name":"E Class","model":"e-class","make_id":"10023","make_seo_name":"mercedes-benz","make_name":"Mercedes-Benz","make":"mercedes-benz","enable_inline_ads":true});
        if (typeof disabledPixel !== 'undefined') {
        dataLayer.push({'pixelToDisable': disabledPixel});
    }
</script>
<!-- 0.36191940307617ms -->
    <div id="body-inner">
                    <!-- Begin comScore Tag -->
    <script>
        var COMSCORE_CLIENT_ID = '7533348',
            _comscore = _comscore || [];

        _comscore.push({ c1: "2", c2: "7533348" });
        (function() {
            var s = document.createElement("script"),
                el = document.getElementsByTagName("script")[0];
            s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
        })();
    </script>
    <noscript>
        <img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=7533348&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cj=1" />
    </noscript>
    <!-- End comScore Tag -->        <script type="text/javascript">
    window.startTime = new Date().getTime();
</script>
<nav id="top-nav">
    <!-- The Car Connection -->
    <div id="nav-main">
        <a id="header-logo"  href="/" title="The Car Connection">The Car Connection</a>
        
<div id="primary-nav">
    <a class="menu-item dd" data-id="new" href="/new-cars">New Cars<span class="line"></span></a>
    <a class="menu-item dd" data-id="used" href="/used-cars">Used Cars<span class="line"></span></a>
    <a class="menu-item dd" data-id="research" href="/rankings">Research<span class="line"></span></a>
    <a class="menu-item" href="/videos">Videos<span class="line"></span></a>
    <a class="menu-item" href="/news">News<span class="line"></span></a>
            <a class="menu-item dd" data-id="finance" href="/car-loans/">Auto Finance<span class="line"></span></a>
        <div class="menu-window" id="new-window" style="display:none;">
        <div class="module make-container">
    <h3>Research New Cars By Make</h3>
        <div class="menu-column" data-column="0">
                                                    <a href="/make/new,acura" title="Acura" data-seo="acura">Acura</a>
                                                            <a href="/make/new,alfa-romeo" title="Alfa Romeo" data-seo="alfa-romeo">Alfa Romeo</a>
                                                            <a href="/make/new,aston-martin" title="Aston Martin" data-seo="aston-martin">Aston Martin</a>
                                                            <a href="/make/new,audi" title="Audi" data-seo="audi">Audi</a>
                                                            <a href="/make/new,bentley" title="Bentley" data-seo="bentley">Bentley</a>
                                                            <a href="/make/new,bmw" title="BMW" data-seo="bmw">BMW</a>
                                                            <a href="/make/new,buick" title="Buick" data-seo="buick">Buick</a>
                                                            <a href="/make/new,cadillac" title="Cadillac" data-seo="cadillac">Cadillac</a>
                                                            <a href="/make/new,chevrolet" title="Chevrolet" data-seo="chevrolet">Chevrolet</a>
                                                            <a href="/make/new,chrysler" title="Chrysler" data-seo="chrysler">Chrysler</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="1">
                                                            <a href="/make/new,dodge" title="Dodge" data-seo="dodge">Dodge</a>
                                                                                <a href="/make/new,ferrari" title="Ferrari" data-seo="ferrari">Ferrari</a>
                                                            <a href="/make/new,fiat" title="FIAT" data-seo="fiat">FIAT</a>
                                                            <a href="/make/new,ford" title="Ford" data-seo="ford">Ford</a>
                                                            <a href="/make/new,genesis" title="Genesis" data-seo="genesis">Genesis</a>
                                                            <a href="/make/new,gmc" title="GMC" data-seo="gmc">GMC</a>
                                                            <a href="/make/new,honda" title="Honda" data-seo="honda">Honda</a>
                                                            <a href="/make/new,hyundai" title="Hyundai" data-seo="hyundai">Hyundai</a>
                                                            <a href="/make/new,infiniti" title="INFINITI" data-seo="infiniti">INFINITI</a>
                                                            <a href="/make/new,jaguar" title="Jaguar" data-seo="jaguar">Jaguar</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="2">
                                                            <a href="/make/new,jeep" title="Jeep" data-seo="jeep">Jeep</a>
                                                            <a href="/make/new,kia" title="Kia" data-seo="kia">Kia</a>
                                                                                <a href="/make/new,lamborghini" title="Lamborghini" data-seo="lamborghini">Lamborghini</a>
                                                            <a href="/make/new,land-rover" title="Land Rover" data-seo="land-rover">Land Rover</a>
                                                            <a href="/make/new,lexus" title="Lexus" data-seo="lexus">Lexus</a>
                                                            <a href="/make/new,lincoln" title="Lincoln" data-seo="lincoln">Lincoln</a>
                                                            <a href="/make/new,maserati" title="Maserati" data-seo="maserati">Maserati</a>
                                                            <a href="/make/new,mazda" title="Mazda" data-seo="mazda">Mazda</a>
                                                            <a href="/make/new,mclaren" title="McLaren" data-seo="mclaren">McLaren</a>
                                                            <a href="/make/new,mercedes-benz" title="Mercedes-Benz" data-seo="mercedes-benz">Mercedes-Benz</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="3">
                                                            <a href="/make/new,mini" title="MINI" data-seo="mini">MINI</a>
                                                            <a href="/make/new,mitsubishi" title="Mitsubishi" data-seo="mitsubishi">Mitsubishi</a>
                                                            <a href="/make/new,nissan" title="Nissan" data-seo="nissan">Nissan</a>
                                                                                <a href="/make/new,porsche" title="Porsche" data-seo="porsche">Porsche</a>
                                                            <a href="/make/new,ram" title="Ram" data-seo="ram">Ram</a>
                                                            <a href="/make/new,rolls-royce" title="Rolls-Royce" data-seo="rolls-royce">Rolls-Royce</a>
                                                            <a href="/make/new,subaru" title="Subaru" data-seo="subaru">Subaru</a>
                                                            <a href="/make/new,tesla" title="Tesla" data-seo="tesla">Tesla</a>
                                                            <a href="/make/new,toyota" title="Toyota" data-seo="toyota">Toyota</a>
                                                            <a href="/make/new,volkswagen" title="Volkswagen" data-seo="volkswagen">Volkswagen</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="4">
                                                            <a href="/make/new,volvo" title="Volvo" data-seo="volvo">Volvo</a>
                                        </div>
</div>
        <div class="type-container module">
    <h3>Research By Category</h3>
        <a href="/category/new,convertible" class="car-name-standard ">Convertibles</a>

            <a href="/category/new,coupes" class="car-name-standard ">Coupes</a>

            <a href="/category/new,crossover" class="car-name-standard ">Crossovers</a>

            <a href="/category/new,electric-car" class="car-name-standard ">Electric Cars</a>

            <a href="/category/new,hatchback" class="car-name-standard ">Hatchbacks</a>

            <a href="/category/new,hybrid" class="car-name-standard last">Hybrids</a>

            <div class="spacer"></div>
            <a href="/category/new,luxury" class="car-name-standard ">Luxury Cars</a>

            <a href="/category/new,minivans-sub" class="car-name-standard ">Minivans</a>

            <a href="/category/new,pickups" class="car-name-standard ">Pickup Trucks</a>

            <a href="/category/new,suvs" class="car-name-standard ">SUVs</a>

            <a href="/category/new,sedans" class="car-name-standard ">Sedans</a>

            <a href="/category/new,wagons" class="car-name-standard last">Wagons</a>

        </div> <!-- module -->
        <a href="/new-cars" class="extra-link larger">Research New Cars &raquo;</a>
    </div>
    <div class="menu-window" id="used-window" style="display:none;">
        <div class="module make-container">
    <h3>Used Cars For Sale Near You</h3>
        <div class="menu-column" data-column="0">
                                                    <a href="/inventory?make=acura&amp;new-flag=0" title="Acura" data-seo="acura">Acura</a>
                                                            <a href="/inventory?make=alfa-romeo&amp;new-flag=0" title="Alfa Romeo" data-seo="alfa-romeo">Alfa Romeo</a>
                                                            <a href="/inventory?make=am-general&amp;new-flag=0" title="AM General" data-seo="am-general">AM General</a>
                                                            <a href="/inventory?make=aston-martin&amp;new-flag=0" title="Aston Martin" data-seo="aston-martin">Aston Martin</a>
                                                            <a href="/inventory?make=audi&amp;new-flag=0" title="Audi" data-seo="audi">Audi</a>
                                                            <a href="/inventory?make=bentley&amp;new-flag=0" title="Bentley" data-seo="bentley">Bentley</a>
                                                            <a href="/inventory?make=bmw&amp;new-flag=0" title="BMW" data-seo="bmw">BMW</a>
                                                            <a href="/inventory?make=buick&amp;new-flag=0" title="Buick" data-seo="buick">Buick</a>
                                                            <a href="/inventory?make=cadillac&amp;new-flag=0" title="Cadillac" data-seo="cadillac">Cadillac</a>
                                                            <a href="/inventory?make=chevrolet&amp;new-flag=0" title="Chevrolet" data-seo="chevrolet">Chevrolet</a>
                                                            <a href="/inventory?make=chrysler&amp;new-flag=0" title="Chrysler" data-seo="chrysler">Chrysler</a>
                                                            <a href="/inventory?make=dodge&amp;new-flag=0" title="Dodge" data-seo="dodge">Dodge</a>
                                                                                <a href="/inventory?make=ferrari&amp;new-flag=0" title="Ferrari" data-seo="ferrari">Ferrari</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="1">
                                                            <a href="/inventory?make=fiat&amp;new-flag=0" title="FIAT" data-seo="fiat">FIAT</a>
                                                            <a href="/inventory?make=ford&amp;new-flag=0" title="Ford" data-seo="ford">Ford</a>
                                                            <a href="/inventory?make=genesis&amp;new-flag=0" title="Genesis" data-seo="genesis">Genesis</a>
                                                            <a href="/inventory?make=gmc&amp;new-flag=0" title="GMC" data-seo="gmc">GMC</a>
                                                            <a href="/inventory?make=honda&amp;new-flag=0" title="Honda" data-seo="honda">Honda</a>
                                                            <a href="/inventory?make=hummer&amp;new-flag=0" title="HUMMER" data-seo="hummer">HUMMER</a>
                                                            <a href="/inventory?make=hyundai&amp;new-flag=0" title="Hyundai" data-seo="hyundai">Hyundai</a>
                                                            <a href="/inventory?make=infiniti&amp;new-flag=0" title="INFINITI" data-seo="infiniti">INFINITI</a>
                                                            <a href="/inventory?make=jaguar&amp;new-flag=0" title="Jaguar" data-seo="jaguar">Jaguar</a>
                                                            <a href="/inventory?make=jeep&amp;new-flag=0" title="Jeep" data-seo="jeep">Jeep</a>
                                                            <a href="/inventory?make=kia&amp;new-flag=0" title="Kia" data-seo="kia">Kia</a>
                                                                                <a href="/inventory?make=lamborghini&amp;new-flag=0" title="Lamborghini" data-seo="lamborghini">Lamborghini</a>
                                                            <a href="/inventory?make=land-rover&amp;new-flag=0" title="Land Rover" data-seo="land-rover">Land Rover</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="2">
                                                            <a href="/inventory?make=lexus&amp;new-flag=0" title="Lexus" data-seo="lexus">Lexus</a>
                                                            <a href="/inventory?make=lincoln&amp;new-flag=0" title="Lincoln" data-seo="lincoln">Lincoln</a>
                                                            <a href="/inventory?make=lotus&amp;new-flag=0" title="Lotus" data-seo="lotus">Lotus</a>
                                                            <a href="/inventory?make=maserati&amp;new-flag=0" title="Maserati" data-seo="maserati">Maserati</a>
                                                            <a href="/inventory?make=mazda&amp;new-flag=0" title="Mazda" data-seo="mazda">Mazda</a>
                                                            <a href="/inventory?make=mclaren&amp;new-flag=0" title="McLaren" data-seo="mclaren">McLaren</a>
                                                            <a href="/inventory?make=mercedes-benz&amp;new-flag=0" title="Mercedes-Benz" data-seo="mercedes-benz">Mercedes-Benz</a>
                                                            <a href="/inventory?make=mini&amp;new-flag=0" title="MINI" data-seo="mini">MINI</a>
                                                            <a href="/inventory?make=mitsubishi&amp;new-flag=0" title="Mitsubishi" data-seo="mitsubishi">Mitsubishi</a>
                                                            <a href="/inventory?make=nissan&amp;new-flag=0" title="Nissan" data-seo="nissan">Nissan</a>
                                                                                <a href="/inventory?make=porsche&amp;new-flag=0" title="Porsche" data-seo="porsche">Porsche</a>
                                                            <a href="/inventory?make=ram&amp;new-flag=0" title="Ram" data-seo="ram">Ram</a>
                                                            <a href="/inventory?make=rolls-royce&amp;new-flag=0" title="Rolls-Royce" data-seo="rolls-royce">Rolls-Royce</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="3">
                                                            <a href="/inventory?make=saturn&amp;new-flag=0" title="Saturn" data-seo="saturn">Saturn</a>
                                                            <a href="/inventory?make=scion&amp;new-flag=0" title="Scion" data-seo="scion">Scion</a>
                                                            <a href="/inventory?make=smart&amp;new-flag=0" title="smart" data-seo="smart">smart</a>
                                                            <a href="/inventory?make=subaru&amp;new-flag=0" title="Subaru" data-seo="subaru">Subaru</a>
                                                            <a href="/inventory?make=tesla&amp;new-flag=0" title="Tesla" data-seo="tesla">Tesla</a>
                                                            <a href="/inventory?make=toyota&amp;new-flag=0" title="Toyota" data-seo="toyota">Toyota</a>
                                                            <a href="/inventory?make=volkswagen&amp;new-flag=0" title="Volkswagen" data-seo="volkswagen">Volkswagen</a>
                                                            <a href="/inventory?make=volvo&amp;new-flag=0" title="Volvo" data-seo="volvo">Volvo</a>
                                        </div>
</div>
        <div class="type-container module">
    <h3>Used Cars by Category</h3>
        <a href="/inventory?category=convertible" class="car-name-standard ">Convertibles</a>

            <a href="/inventory?category=coupes" class="car-name-standard ">Coupes</a>

            <a href="/inventory?category=crossover" class="car-name-standard ">Crossovers</a>

            <a href="/inventory?category=diesel" class="car-name-standard ">Diesel Cars</a>

            <a href="/inventory?category=hatchback" class="car-name-standard ">Hatchbacks</a>

            <a href="/inventory?category=hybrid" class="car-name-standard last">Hybrids</a>

            <div class="spacer"></div>
            <a href="/inventory?category=pickups" class="car-name-standard ">Pickup Trucks</a>

            <a href="/inventory?category=sedans" class="car-name-standard ">Sedans</a>

            <a href="/inventory?category=sports-cars" class="car-name-standard ">Sports Cars</a>

            <a href="/inventory?category=suvs" class="car-name-standard ">SUVs</a>

            <a href="/inventory?category=vans" class="car-name-standard ">Vans</a>

            <a href="/inventory?category=wagons" class="car-name-standard last">Wagons</a>

        </div> <!-- module -->
        <a href="/used-cars" class="extra-link larger">Browse Used Cars For Sale &raquo;</a>
    </div>
    <div class="menu-window clear" id="research-window" style="display:none;">
        <div class="column">
            <h3>Reviews</h3>
            <a href="/news/compare" title="Head To Head Compare Reviews">Head to Head</a>
            <a href=" /news/first-drives" title="First Drive Reviews">First Drives </a>
            <a href="/news/video-reviews" title="Video Reviews">Video Reviews</a>
            <a class="see-all" href="/reviews" title="Read All Reviews">All Reviews &#187;</a>
        </div>
        <div class="column">
            <h3>Rankings</h3>
                                            <a href="/rankings/cars" title="Cars" >
                    Cars                </a>
                                <a href="/rankings/suvs" title="SUVs" >
                    SUVs                </a>
                                <a href="/rankings/trucks" title="Trucks" >
                    Trucks                </a>
                                <a href="/rankings/vans" title="Vans/Minivans" >
                    Vans/Minivans                </a>
                                <a href="/rankings/hybrids-electrics" title="Hybrids/Electrics" >
                    Hybrids/Electrics                </a>
                                <a class="see-all" title="TCC Top Ranked Cars" href="/rankings">All Rankings &#187;</a>
        </div>
        <div class="column">
            <h3>Advice</h3>
            <a href="/car-compare">Compare Cars</a>
                            <a href="/advice/buying-guides" title="Buying Guides">Buying Guides</a>
                            <a href="/advice/maintenance" title="Maintenance Guides">Maintenance Guides</a>
                            <a href="/advice/finance" title="Finance Guides">Finance Guides</a>
                            <a href="/advice/the-basics" title="The Basics">The Basics</a>
                        <a class="see-all" href="/tips" title="The Basics">All Advice &#187;</a>
        </div>
        <div class="column last">
            <h3>Awards</h3>
                            <a id="bctb" href="/bestcartobuy/2020" title="Check Our Best Car to Buy 2020">Best Car to Buy <span>2020</span>&nbsp;&raquo;</a>
                                        <a id="dc" href="/driverschoice/2020" title="Check Driver's Choice 2020">Driver's Choice <span>2020</span>&nbsp;&raquo;</a>
                    </div>
    </div>
    <div class="menu-window" id="finance-window" style="display:none;">
        <div class="column">
            <a href="/car-loans/apply/" title="Apply For Car Loan" class="extra-link">Start a Loan Request Form Today!</a>
            <a href="/car-loans/finance-guides/" title="Get Car Financing Advice">Car Financing Advice</a>
            <a href="/resources/" title="Access Car Financing Resources">Resource Center</a>
            <a href="/car-loans/payment-calculator/" title="Calculate Monthly Payments">Monthly Payment Calculator</a>
            <a href="/car-loans/loan-estimator/" title="Estimate Car Loan">Car Loan Estimator</a>
        </div>
    </div>
</div>
<div id="masterSearch">
    <div class="global-google-search" id="google-search-form-0" style="width: 210px;">

    <script>
        (function() {
            var cx = '001937828977938864696:wubol2i6jwo';
            var gcse = document.createElement('script');
            gcse.type = 'text/javascript';
            gcse.async = true;
            gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(gcse, s);
        })();
    </script>
    <gcse:searchbox-only resultsUrl="/searchresults"></gcse:searchbox-only>
    
<!-- Google CSE Search Box Begins  -->
<!-- Google CSE Search Box Ends -->
</div>
</div>
    </div>
</nav>
<div id="top-ad-with-breadcrumbs">
    <div id="banner-container">
        <div style="width:728px;height:90px;margin: 0 auto;">
                            <!-- GPT ADS 728x90 code begin -->
<div id="ad-1" class="ad ad-r-t" style="max-width: 728px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-1');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-1') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
                    </div>
    </div>
    <div id="top-toolbar-container">
        <div id="top-toolbar">
                                <div id="bc_container">
        <div id="breadcrumbs" class="clear">
            <div id="bc_title">
                <a id="a_bc_home" href="/"><span>Home</span></a>
            </div>
            <div class="bc_separator"></div>
                                                                                                                                                    <div id="bc_child_0">
                        <a id="a_bc_0" class="bc_link" href="/new-cars">
                            New Cars                        </a>
                                            </div>

                                                                                                        <div class="bc_separator"></div>
                                                            <div id="bc_child_1">
                        <a id="a_bc_1" class="bc_link bc_link_dd" href="/make/new,mercedes-benz">
                            Mercedes-Benz<div class="bc_triangle"></div>                        </a>
                                                    <div id="div_bc_1" class="bc_dropdown"><div class="module" id="by-make">
            <div class="block-header">Make</div>
        <div class="block-inner">
                            <div class="menu-column">
                                            <a class="add-zip " href="/make/new,acura" title="Acura">Acura</a>
                                            <a class="add-zip " href="/make/new,alfa-romeo" title="Alfa Romeo">Alfa Romeo</a>
                                            <a class="add-zip " href="/make/new,aston-martin" title="Aston Martin">Aston Martin</a>
                                            <a class="add-zip " href="/make/new,audi" title="Audi">Audi</a>
                                            <a class="add-zip " href="/make/new,bentley" title="Bentley">Bentley</a>
                                            <a class="add-zip " href="/make/new,bmw" title="BMW">BMW</a>
                                            <a class="add-zip " href="/make/new,buick" title="Buick">Buick</a>
                                            <a class="add-zip " href="/make/new,cadillac" title="Cadillac">Cadillac</a>
                                            <a class="add-zip " href="/make/new,chevrolet" title="Chevrolet">Chevrolet</a>
                                            <a class="add-zip " href="/make/new,chrysler" title="Chrysler">Chrysler</a>
                                            <a class="add-zip " href="/make/new,dodge" title="Dodge">Dodge</a>
                                    </div>
                            <div class="menu-column">
                                            <a class="add-zip " href="/make/new,ferrari" title="Ferrari">Ferrari</a>
                                            <a class="add-zip " href="/make/new,fiat" title="FIAT">FIAT</a>
                                            <a class="add-zip " href="/make/new,ford" title="Ford">Ford</a>
                                            <a class="add-zip " href="/make/new,genesis" title="Genesis">Genesis</a>
                                            <a class="add-zip " href="/make/new,gmc" title="GMC">GMC</a>
                                            <a class="add-zip " href="/make/new,honda" title="Honda">Honda</a>
                                            <a class="add-zip " href="/make/new,hyundai" title="Hyundai">Hyundai</a>
                                            <a class="add-zip " href="/make/new,infiniti" title="INFINITI">INFINITI</a>
                                            <a class="add-zip " href="/make/new,jaguar" title="Jaguar">Jaguar</a>
                                            <a class="add-zip " href="/make/new,jeep" title="Jeep">Jeep</a>
                                            <a class="add-zip " href="/make/new,kia" title="Kia">Kia</a>
                                    </div>
                            <div class="menu-column">
                                            <a class="add-zip " href="/make/new,lamborghini" title="Lamborghini">Lamborghini</a>
                                            <a class="add-zip " href="/make/new,land-rover" title="Land Rover">Land Rover</a>
                                            <a class="add-zip " href="/make/new,lexus" title="Lexus">Lexus</a>
                                            <a class="add-zip " href="/make/new,lincoln" title="Lincoln">Lincoln</a>
                                            <a class="add-zip " href="/make/new,maserati" title="Maserati">Maserati</a>
                                            <a class="add-zip " href="/make/new,mazda" title="Mazda">Mazda</a>
                                            <a class="add-zip " href="/make/new,mclaren" title="McLaren">McLaren</a>
                                            <a class="add-zip selected" href="/make/new,mercedes-benz" title="Mercedes-Benz">Mercedes-Benz</a>
                                            <a class="add-zip " href="/make/new,mini" title="MINI">MINI</a>
                                            <a class="add-zip " href="/make/new,mitsubishi" title="Mitsubishi">Mitsubishi</a>
                                            <a class="add-zip " href="/make/new,nissan" title="Nissan">Nissan</a>
                                    </div>
                            <div class="menu-column">
                                            <a class="add-zip " href="/make/new,porsche" title="Porsche">Porsche</a>
                                            <a class="add-zip " href="/make/new,ram" title="Ram">Ram</a>
                                            <a class="add-zip " href="/make/new,rolls-royce" title="Rolls-Royce">Rolls-Royce</a>
                                            <a class="add-zip " href="/make/new,subaru" title="Subaru">Subaru</a>
                                            <a class="add-zip " href="/make/new,tesla" title="Tesla">Tesla</a>
                                            <a class="add-zip " href="/make/new,toyota" title="Toyota">Toyota</a>
                                            <a class="add-zip " href="/make/new,volkswagen" title="Volkswagen">Volkswagen</a>
                                            <a class="add-zip " href="/make/new,volvo" title="Volvo">Volvo</a>
                                    </div>
                    </div>
    </div> <!-- module -->
</div>
                                            </div>

                                                                                                        <div class="bc_separator"></div>
                                                            <div id="bc_child_2">
                        <a id="a_bc_2" class="bc_link bc_link_dd" href="/cars/mercedes-benz_e-class">
                            E Class<div class="bc_triangle"></div>                        </a>
                                                    <div id="div_bc_2" class="bc_dropdown"><div class="module" id="by-model">
    <div class="block-header">Model</div>
    <div class="block-inner">
                    <div class="divmodels">
                <h4>New</h4>
                                    <div class="menu-column">
                                                                                    <a class="" href="/cars/mercedes-benz_a-class" title="A Class">A Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_amg-gt" title="AMG GT">AMG GT</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_c-class" title="C Class">C Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_cla-class" title="CLA Class">CLA Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_cls-class" title="CLS Class">CLS Class</a>
                                                                        </div>
                                    <div class="menu-column">
                                                                                    <a class="selected" href="/cars/mercedes-benz_e-class" title="E Class">E Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_eqc" title="EQC">EQC</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_g-class" title="G Class">G Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_gla-class" title="GLA Class">GLA Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_glb" title="GLB">GLB</a>
                                                                        </div>
                                    <div class="menu-column">
                                                                                    <a class="" href="/cars/mercedes-benz_glb-class" title="GLB Class">GLB Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_glc-class" title="GLC Class">GLC Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_gle-class" title="GLE Class">GLE Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_gls-class" title="GLS Class">GLS Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_metris" title="Metris">Metris</a>
                                                                        </div>
                                    <div class="menu-column">
                                                                                    <a class="" href="/cars/mercedes-benz_s-class" title="S Class">S Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_sl-class" title="SL Class">SL Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_slc-class" title="SLC Class">SLC Class</a>
                                                                        </div>
                            </div>
                            <div class="divmodels" style="margin-top: 15px;">
                <h4>Used</h4>
                                    <div class="menu-column">
                                                                                    <a class="" href="/cars/mercedes-benz_cl-class" title="CL Class">CL Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_clk-class" title="CLK Class">CLK Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_gl-class" title="GL Class">GL Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_glk-class" title="GLK Class">GLK Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_m-class" title="M Class">M Class</a>
                                                                        </div>
                                    <div class="menu-column">
                                                                                    <a class="" href="/cars/mercedes-benz_r-class" title="R Class">R Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_slk-class" title="SLK Class">SLK Class</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_slr-mclaren" title="SLR McLaren">SLR McLaren</a>
                                                                                                                <a class="" href="/cars/mercedes-benz_sls-amg" title="SLS AMG">SLS AMG</a>
                                                                        </div>
                            </div>
            </div>
</div>
</div>
                                            </div>

                                                                                                        <div class="bc_separator"></div>
                                                            <div id="bc_child_3">
                        <a id="a_bc_3" class="bc_link bc_link_dd" href="/overview/mercedes-benz_e-class_2020">
                            2020<div class="bc_triangle"></div>                        </a>
                                                    <div id="div_bc_3" class="bc_dropdown"><div class="divyears"><h4>New</h4><div class="module by-year">
    <div class="block-header">By Year</div>
    <div class="block-inner">
                                    <div class="menu-column">
                                                                    <a href="/overview/mercedes-benz_e-class_2020" class="selected">2020</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2019" class="">2019</a>

                                    </div>
                        </div>
</div> <!-- module -->
</div><div class="divyears"><h4>Used</h4><div class="module by-year">
    <div class="block-header">By Year</div>
    <div class="block-inner">
                                    <div class="menu-column">
                                                                    <a href="/overview/mercedes-benz_e-class_2018" class="">2018</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2017" class="">2017</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2016" class="">2016</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2015" class="">2015</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2014" class="">2014</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2013" class="">2013</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2012" class="">2012</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2011" class="">2011</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2010" class="">2010</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2009" class="">2009</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2008" class="">2008</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2007" class="">2007</a>

                                    </div>
                            <div class="menu-column">
                                                                    <a href="/overview/mercedes-benz_e-class_2006" class="">2006</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2005" class="">2005</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2004" class="">2004</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2003" class="">2003</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2002" class="">2002</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2001" class="">2001</a>

                                                                    <a href="/overview/mercedes-benz_e-class_2000" class="">2000</a>

                                                                    <a href="/overview/mercedes-benz_e-class_1999" class="">1999</a>

                                                                    <a href="/overview/mercedes-benz_e-class_1998" class="">1998</a>

                                                                    <a href="/overview/mercedes-benz_e-class_1997" class="">1997</a>

                                                                    <a href="/overview/mercedes-benz_e-class_1996" class="">1996</a>

                                                                    <a href="/overview/mercedes-benz_e-class_1995" class="">1995</a>

                                    </div>
                        </div>
</div> <!-- module -->
</div></div>
                                            </div>

                                    </div>
    </div>
    <script>
        (function () {
            var $links = $('.bc_link'),
                $dropdowns = $('.bc_dropdown'),
                open = false,
                $closeBtns = $('<span class="close-me">X</span>');

            //$dropdowns.append($closeBtns);

            $links.click(function (e) {
                hasDropdown($(this), e);
                $dropdowns.hide();
                var idx = $links.index($(this)),
                    $menu = $('#div_bc_' + idx) ;
                if ($menu.hasClass('open')) {
                    $dropdowns.removeClass('open');
                }
                else {
                    $dropdowns.removeClass('open');
                    $menu.show().addClass('open');
                }
            });
            $('html').click(function (event) {
                if(!$(event.target).is('.bc_dropdown, .bc_link, .module')) {
                    $dropdowns.hide().removeClass('open');
                }
            });

            function hasDropdown($link, event) {
                var num = $link.attr('id').slice(-1),
                    $elem = $('#div_bc_' + num).length == 0;
                if (!$elem) {
                    event.preventDefault();
                }
            }
        }());
    </script>
                    </div>
    </div>
</div>
        <div id="tcc3-global-container">
            
<h1>2020 Mercedes-Benz E Class Preview</h1>



<div id="content">
    <div id="main-column">
                    <div id="top-section">
                                <div id="pq-block">
                    <div class="coming-soon-text">Our review of the 2020 Mercedes-Benz E Class is coming soon. You can get a quick quote for a 2020 Mercedes-Benz E Class if you're interested in purchasing one.</div>
                        <div class="submitLead">
                            <input type="text" name="qq_zipcode" class="zipcode" maxlength="5" value="" placeholder="Zip Code"/>
                            <a class="zipUpdateBtn" href="/quickquotes/mercedes-benz_e-class_2020">Get a Quick Quote</a>
                        </div>
                </div>
                                    <div id="lead-image">
                        <div class="current-year-photos">
                            <a  title="2020 Mercedes-Benz E Class Pictures"   href="/photos/mercedes-benz_e-class_2020">
                                <img class="fitfill" src="https://images.hgmsites.net/sml/2020-mercedes-benz-e-class_100732317_s.jpg" alt="2020 Mercedes-Benz E Class" onerror="this.src='/images/noimage.gif'"/>                                <div class="photos-link ion-camera">View Photos</div>
                            </a>
                        </div>
                    </div>
                                <div class="clear"></div>
            </div>
            <div id="email-subscribe-top" class="make-model-news-subscription subscription-email">
                <div class="email-form">
                    <div class="email-form-label">Sign up for Email Updates <br />
                        <span>Get updates about the 2020 Mercedes-Benz E Class emailed to you</span>
                    </div>
                    <form onsubmit="return false;">
                        <input type="text" name="email"  class="subscription-email" placeholder="Email Address" />
                        <input type="hidden" name="type" value="tcc_new" class="subscription-type" />
                        <input type="hidden" name="make" value="mercedes-benz" />
                        <input type="hidden" name="model" value="e-class" />
                        <div data-action="/subscribe/addnew/" class="btn" id="add-email">Get Updates</div>
                    </form>
                    <div class="email-message"></div>
                </div>
                <div class="email-consent">
                    I agree to receive emails from The Car Connection. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
                </div>

            </div>
        
                <div id="left-column">
            <div class="nav-menu-block">
                
<!-- Reviews Pricing Specs Inventory -->
<div class="top-nav-wrapper">
    <div id="ymm-nav">
                    <a href="#"
               class="active"
            >
                Overview
            </a>
                        <a href="/news/e-class"
               class=""
            >
                News
            </a>
                    
                                    <a id="ymm-nav-pq-btn" href="/price/mercedes-benz_e-class_2020"
                    class="" >
                    Build &amp; Price
                </a>
                                        <a id="ymm-nav-specs-btn" href="/specifications/mercedes-benz_e-class_2020"
               class="" >
                Specs
            </a>
                                            <a id="ymm-nav-pq-btn" href="/photos/mercedes-benz_e-class_2020"
                    class="" >
                    Photos
                </a>
                                        <a id="ymm-nav-classified-btn" href="/inventory?make=mercedes-benz&amp;model=e-class&amp;year=2020"
               class=""
               data-make="mercedes-benz"
               data-model="e-class">
                Inventory
            </a>
            </div>
</div>
<script>
    var navTabWidth = 100 / 6;
    $('#ymm-nav a').css('width', navTabWidth + '%');
    $(function() {
        hgm.pingView(0, 30010581);
        var $topNav = $('#ymm-nav');
        $topNav.find('a.active').click(function (e) {
            e.preventDefault();
        });
        $('.top-nav-wrapper').waypoint({
            handler: function (direction) {
                if (direction === 'down') {
                    $topNav.addClass('fixed');
                } else {
                    $topNav.removeClass('fixed');
                }
            }
        });
    });
</script>
            </div>
            <div id="overview-content">
                                    <div class="section-title">Specs</div>
                                            <div class="specs-set-item">
                            <span class="key">Gas Mileage</span>
                            <span class="value">23 mpg City/32 mpg Hwy</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">Engine</span>
                            <span class="value">Intercooled Turbo Premium Unleaded I-4, 2.0 L</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">EPA Class</span>
                            <span class="value">Mid-Size Cars</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">Style Name</span>
                            <span class="value">E 350 RWD Sedan</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">Drivetrain</span>
                            <span class="value">Rear Wheel Drive</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">Passenger Capacity</span>
                            <span class="value">5</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">Passenger Doors</span>
                            <span class="value">4</span>
                            <div class="clear" ></div>
                        </div>
                                            <div class="specs-set-item">
                            <span class="key">Body Style</span>
                            <span class="value">4dr Car</span>
                            <div class="clear" ></div>
                        </div>
                                        <a class="see-more" href="/specifications/mercedes-benz_e-class_2020_e-350-rwd-sedan">More Specs »</a>
                                                    <div class="section-title">News</div>
                    
<div class="small module" id="news-table">
    <div class="block-header">
                    <h3 class="block-title"> </h3>
            </div>
    <div class="block-inner">
        
                                <div id="two-columns">
                                                    <div class="news-item">
                        <div class="news-image">
                            <a href="/news/1123697_2020-mercedes-benz-e350-boasts-more-powerful-engine">
                                <div class="img-wrapper">
                                    <img class="fitfill" src="https://images.hgmsites.net/sml/2019-mercedes-benz-e-class_100691375_s.jpg" alt="2020 Mercedes-Benz E350 boasts more powerful engine"/>                                </div>
                            </a>
                        </div>
                        <div class="title-block">
                            <a class="title-link title-test" href="/news/1123697_2020-mercedes-benz-e350-boasts-more-powerful-engine">2020 Mercedes-Benz E350 boasts more powerful engine</a>
                                                            <div class="excerpt">The 2020 Mercedes-Benz E-Class adds power and features to the renamed entry-level 2020 E350 sedan. Last year's E300 is renamed E350 thanks to a new 2.0-liter turbo-4 engine that puts out 255 horsepower, a boost of 14 hp compared to 2019. Torque...<a class="read-more" href="/news/1123697_2020-mercedes-benz-e350-boasts-more-powerful-engine">Read More&raquo;</a></div>
                                                    </div>
                        <div style="clear: both;"></div>
                    </div>
                                            <hr></hr>
                        <div class="spacer"></div>
                                                                            <div class="news-item">
                        <div class="news-image">
                            <a href="/news/1118117_age-against-the-machine-iihs-finds-that-autonomous-safety-systems-arent-up-to-human-level-yet">
                                <div class="img-wrapper">
                                    <img src="https://static.hgmsites.net/images/cache/consumer-reports-tests-tesla-model-3-braking-credit-consumer-reports_100653529_130x80.jpg" alt="Age against the machine: IIHS finds that autonomous safety systems aren’t up to human level, yet" width="130" height="80"/>                                </div>
                            </a>
                        </div>
                        <div class="title-block">
                            <a class="title-link title-test" href="/news/1118117_age-against-the-machine-iihs-finds-that-autonomous-safety-systems-arent-up-to-human-level-yet">Age against the machine: IIHS finds that autonomous safety systems aren’t up to human level, yet</a>
                                                            <div class="excerpt">In case you needed yet another reason not to tune out when autopilot is active, an IIHS study released on Tuesday has found that advanced driver assist systems aren&rsquo;t as robust as normal human reaction time. MORE: IIHS faults Uber for...<a class="read-more" href="/news/1118117_age-against-the-machine-iihs-finds-that-autonomous-safety-systems-arent-up-to-human-level-yet">Read More&raquo;</a></div>
                                                    </div>
                        <div style="clear: both;"></div>
                    </div>
                                            <hr></hr>
                        <div class="spacer"></div>
                                                                            <div class="news-item">
                        <div class="news-image">
                            <a href="/news/1109165_mercedes-benz-recalls-354000-vehicles-due-to-fire-risk">
                                <div class="img-wrapper">
                                    <img src="https://static.hgmsites.net/images/cache/2017-mercedes-benz-c-class_100584413_130x80.jpg" alt="Mercedes-Benz recalls 354,000 vehicles due to fire risk" width="130" height="80"/>                                </div>
                            </a>
                        </div>
                        <div class="title-block">
                            <a class="title-link title-test" href="/news/1109165_mercedes-benz-recalls-354000-vehicles-due-to-fire-risk">Mercedes-Benz recalls 354,000 vehicles due to fire risk</a>
                                                            <div class="excerpt">Mercedes-Benz has issued a massive recall affecting more than 354,000 vehicles from the 2015, 2016, and 2017 model years. According to the National Highway Traffic Safety Administration, some of those cars may be at risk of catching fire. The...<a class="read-more" href="/news/1109165_mercedes-benz-recalls-354000-vehicles-due-to-fire-risk">Read More&raquo;</a></div>
                                                    </div>
                        <div style="clear: both;"></div>
                    </div>
                                                                    </div>
                        </div>
</div>


                    <a class="see-more" href="/news/e-class" >More News &#187;</a>                
                                    

<div id="previous-years-reviews">
    <div class="section-title"> Previous Year Models</div>
            <div class="previous-years-review">
            <div class="year-previous-year">
                2019            </div>
            <div class="image-previous-years">
                <a class="image-link" href="/overview/mercedes-benz_e-class_2019" title="2019 Mercedes-Benz E Class review">
                    <img class="fitfill" src="https://images.hgmsites.net/sml/2019-mercedes-benz-e-class_100696454_s.jpg" alt="2019 Mercedes-Benz AMG E 53 coupe"/>                </a>
            </div>
            <div class="details-previous-years">
                <a href="/overview/mercedes-benz_e-class_2019">
                    <div class="dial-rating-previous-years">
                        <style>
    .dial-value-78-animation::before {
        animation: dial-value-78 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-78 {
                    42.734042735043% {
                border-right-color: transparent;
            }
            42.735042735043% {
                border-right-color: #7DBC13;
            }
                            85.469085470085% {
                border-top-color: transparent;
            }
            85.470085470085% {
                border-top-color: #7DBC13;
            }
                100% {
            border-top-color: #7DBC13;
            border-right-color: #7DBC13;
            transform: rotate(210.6deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-78">
        <span class="ratingNumber">7.8</span>
    </div>
    <div class="dial-label">Expert Rating</div>
</div>
<script>
    $(function () {
        $('.dial-value-78').addClass('dial-value-78-animation');
    });
</script>
                        <div class="expert-rating-text">Expert Rating</div>
                    </div>
                    <div class="msrp-previous-years">
                        $53,500 - $108,850                    </div>
                                            <div class="bottom-line-previous-years">With two new engine options, the 2019 Mercedes-Benz E-Class reminds us that life is good at the top.</div>
                                                                <div class="likes-dislikes-previous-years">
                                                                                        <div class="likes-dislikes likes">
                                    <ul>
                                                                                    <li><div class="check-mark"></div><div class="text">Gorgeous in any form</div></li>
                                                                                    <li><div class="check-mark"></div><div class="text">Turbocharged thrust</div></li>
                                                                                    <li><div class="check-mark"></div><div class="text">Beautiful interior</div></li>
                                                                                    <li><div class="check-mark"></div><div class="text">Loaded with safety tech</div></li>
                                                                                    <li><div class="check-mark"></div><div class="text">Self-driving, sort of</div></li>
                                                                            </ul>
                                </div>
                                <!--                                     <div class="likes-dislikes dislikes">
                                        <ul>
                                                                                            <li><div class="check-mark"></div><div class="text">Infotainment could be better</div></li>
                                                                                            <li><div class="check-mark"></div><div class="text">Coupes are cozy</div></li>
                                                                                            <li><div class="check-mark"></div><div class="text">Spartan standard spec</div></li>
                                                                                            <li><div class="check-mark"></div><div class="text">Options add up</div></li>
                                                                                    </ul>
                                    </div>
                                 -->
                                                    </div>
                                    </a>
            </div>
        </div>
            <div class="previous-years-review">
            <div class="year-previous-year">
                2018            </div>
            <div class="image-previous-years">
                <a class="image-link" href="/overview/mercedes-benz_e-class_2018" title="2018 Mercedes-Benz E Class review">
                    <img class="fitfill" src="https://images.hgmsites.net/sml/2018-mercedes-benz-e-class_100627196_s.jpg" alt="2018 Mercedes-Benz E-Class (E400 Coupe)"/>                </a>
            </div>
            <div class="details-previous-years">
                <a href="/overview/mercedes-benz_e-class_2018">
                    <div class="dial-rating-previous-years">
                        <style>
    .dial-value-83-animation::before {
        animation: dial-value-83 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-83 {
                    40.159642570281% {
                border-right-color: transparent;
            }
            40.160642570281% {
                border-right-color: #7DBC13;
            }
                            80.320285140562% {
                border-top-color: transparent;
            }
            80.321285140562% {
                border-top-color: #7DBC13;
            }
                100% {
            border-top-color: #7DBC13;
            border-right-color: #7DBC13;
            transform: rotate(224.1deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-83">
        <span class="ratingNumber">8.3</span>
    </div>
    <div class="dial-label">Expert Rating</div>
</div>
<script>
    $(function () {
        $('.dial-value-83').addClass('dial-value-83-animation');
    });
</script>
                        <div class="expert-rating-text">Expert Rating</div>
                    </div>
                    <div class="msrp-previous-years">
                        $52,950 - $106,950                    </div>
                                            <div class="bottom-line-previous-years">The 2018 Mercedes-Benz E-Class goes to excess--the right kinds of excess--to preserve its best-of status.</div>
                                                        </a>
            </div>
        </div>
            <div class="previous-years-review">
            <div class="year-previous-year">
                2017            </div>
            <div class="image-previous-years">
                <a class="image-link" href="/overview/mercedes-benz_e-class_2017" title="2017 Mercedes-Benz E Class review">
                    <img title="Carmel Valley, 2016" class="fitfill" src="https://images.hgmsites.net/sml/2017-mercedes-benz-e-class_100556972_s.jpg" alt="2017 Mercedes-Benz E-Class (E300)"/>                </a>
            </div>
            <div class="details-previous-years">
                <a href="/overview/mercedes-benz_e-class_2017">
                    <div class="dial-rating-previous-years">
                        <style>
    .dial-value-82-animation::before {
        animation: dial-value-82 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-82 {
                    40.649406504065% {
                border-right-color: transparent;
            }
            40.650406504065% {
                border-right-color: #7DBC13;
            }
                            81.29981300813% {
                border-top-color: transparent;
            }
            81.30081300813% {
                border-top-color: #7DBC13;
            }
                100% {
            border-top-color: #7DBC13;
            border-right-color: #7DBC13;
            transform: rotate(221.4deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-82">
        <span class="ratingNumber">8.2</span>
    </div>
    <div class="dial-label">Expert Rating</div>
</div>
<script>
    $(function () {
        $('.dial-value-82').addClass('dial-value-82-animation');
    });
</script>
                        <div class="expert-rating-text">Expert Rating</div>
                    </div>
                    <div class="msrp-previous-years">
                        $52,150 - $72,400                    </div>
                                            <div class="bottom-line-previous-years">With the 2017 E-Class, Mercedes-Benz is pushing the boundaries of its autonomous driving technology, and backing it up with S-Class style.</div>
                                                        </a>
            </div>
        </div>
    </div>
                
                <div class="section-title"> Inventory</div>
                    <div id="listings-ppc-block"></div>

<script id="car-ppc-template" type="text/x-handlebars-template" data-count="{{ this.count }}">
{{#each this}}
    <div class="car {{#if_eq per_click compare=1}}ppc{{else}}noppc{{/if_eq}}{{#unless_eq model_id compare="20000468"}} tall{{/unless_eq}}"
        data-tracking-id="3825257915" data-vin="{{vin}}">
        {{#if_eq per_click compare=1}}<span class="sponsored-msg">Sponsored Result</span>{{else}}<span class="sponsored-msg">&nbsp;</span>{{/if_eq}}
        <div class="lead-image">
            {{#if images}}
            <img src="{{listingThumbnail images.0.}}" onerror="this.src='/images/noimage.gif'" alt="{{year}} {{make}} {{model}}"/>
            {{else}}
            <img src='{{ fallbackLeadImageUrl }}' onerror="this.src='/images/noimage.gif'" alt="{{make}}"/>
            {{/if}}

        </div>
        <div class="details">
            <div class="price">{{formatCurrency price}}{{#if_eq per_click compare=1}}<span></span>{{/if_eq}}</div>
            <div class="name">
                <span>{{#if_eq new_flag compare=1}}New {{else}}Used {{/if_eq}}</span>{{year}}{{#unless_eq make_id compare="10023"}} {{make}}{{/unless_eq}}{{#unless_eq model_id compare="20000468"}} {{model}}{{/unless_eq}}
            </div>
            <div class="mileage">Mileage: {{formatMileage mileage new_flag}}</div>
        </div>
    </div>
{{/each}}
<div class="clear"></div>
</script>

<script id="car-ppc-template2" type="text/x-handlebars-template">
{{#each this}}
    <div class="car {{#if_eq per_click compare=1}}ppc{{else}}noppc{{/if_eq}}{{#unless_eq model_id compare="20000468"}} tall{{/unless_eq}}" data-vin="{{vin}}">
        <div class="lead-image">
            {{#if images}}
            <img src="{{listingThumbnail images.0.}}" onerror="this.src='/images/noimage.gif'" />
            {{else}}
            <img src='{{ fallbackLeadImageUrl }}' onerror="this.src='/images/noimage.gif'" />
            {{/if}}
        </div>
        <div class="details">
            <div class="price">{{formatCurrency price noPricingText="No Price"}}{{#if_eq per_click compare=1}}<span></span>{{/if_eq}}</div>
            <div class="name">
                <span>{{#if_eq new_flag compare=1}}New {{else}}Used {{/if_eq}}</span>{{year}}{{#unless_eq make_id compare="10023"}} {{make}}{{/unless_eq}}{{#unless_eq model_id compare="20000468"}} {{model}}{{/unless_eq}}
            </div>
           <div class="mileage">{{formatMileage mileage new_flag noMileageText="" postText="&nbsp;mi"}}</div>
        </div>
    </div>
{{/each}}
<div class="clear"></div>
</script>

<script id="car-ppc-template3" type="text/x-handlebars-template">
    {{#each this}}
    <div class="car {{#if_eq per_click compare=1}}ppc{{else}}noppc{{/if_eq}}{{#unless_eq model_id compare="20000468"}} tall{{/unless_eq}}" data-vin="{{vin}}">
        <div class="lead-image">
            {{#if images}}
            <img src="{{listingThumbnail images.0.}}" onerror="this.src='/images/noimage.gif'" />
            {{else}}
            <img src='{{ fallbackLeadImageUrl }}' onerror="this.src='/images/noimage.gif'" />
            {{/if}}
        </div>
        <div class="details">

            <div class="features">
                <div class="name">{{year}} {{make}} {{model}} <span class="trim">{{trim}}</span></div>
                <ul>
                    <li><span class="feature-label">Mileage:</span> {{formatMileage mileage new_flag }}</li>
                    <li><span class="feature-label">Location:</span> {{ city }}, {{ state }}</li>
                    {{#if dealer_name}}
                    <li><span class="feature-label">Seller:</span> {{dealer_name}}</li>
                    {{/if}}
                    {{#if phone}}
                    <li><span class="feature-label">Phone:</span> {{formatPhone phone}}</li>
                    {{/if}}
                </ul>
            </div>
        </div>
        <div class="pricediv">
            <div class="price">{{formatCurrency price noPricingText="N/A"}}{{#if_eq per_click compare=1}}<span></span>{{/if_eq}}</div>
        </div>
    <div class="clear"></div>
    </div>
    {{/each}}
    <div class="clear"></div>
</script>

<script>
    var listingsPpc,
        lppciType = '3',
        lppciTest = false
    ;

    if (!lppciType) {
        //lppciType = Math.floor((Math.random() * 2) + 1);
        //lppciTest = false;
        lppciType = 1;
        lppciTest = false;
    }

    if (lppciType == 1) {
        listingsPpc = new hgm.listings.ppc($('#listings-ppc-block'), $('#car-ppc-template'), 'listings-ppc-wrapper');
    } else {
        listingsPpc = new hgm.listings.ppc($('#listings-ppc-block'), $('#car-ppc-template' + lppciType), 'listings-ppc-wrapper' + lppciType);
    }

    listingsPpc.setClickTracker('Overview v' + lppciType);


    if (lppciTest) {
        if (lppciType == 1) {
            listingsPpc.setNumListings(8);
            listingsPpc.setNumPpcListings(4);
            listingsPpc.setNumColumns(4);
        } else {
            listingsPpc.setNumListings(9);
            listingsPpc.setNumPpcListings(4);
            listingsPpc.setNumColumns(3);
        }
    } else {
        listingsPpc.setNumListings(3);
        listingsPpc.setNumPpcListings(3);
        listingsPpc.setNumColumns(1);
    }

    listingsPpc.setParentContainer(".listings-and-ppc");
    listingsPpc.setListingsUrl("/inventory?make=mercedes-benz&model=e-class&new-flag=1");
    listingsPpc.setMake("mercedes-benz");
    listingsPpc.setModel("e-class");
    listingsPpc.setNewFlag("1");
    listingsPpc.setCategory("");
    listingsPpc.setCategories("");
    listingsPpc.setYearLow("");
    listingsPpc.setYearHigh("");
    listingsPpc.setPriceLow("");
    listingsPpc.setPriceHigh("");
    listingsPpc.setNoPriceFlag("1");
    listingsPpc.setTitleStr("");
    listingsPpc.setSource();

    $(function() {
        var listingsPpcZip = "",
            listingsPpcRange = "75"
        ;

        listingsPpc.setRange('75');

        if (listingsPpcZip) {
            listingsPpc.setZip(listingsPpcZip);
            listingsPpc.load();
        } else {
            hgm.geo.getZip().then(listingsZipDetected, listingsZipDetected);
        }

        function listingsZipDetected(zip) {
            listingsPpc.setZip(zip);
            listingsPpc.load();
        }
    });
</script>
                <a class="see-more" href="/inventory?make=mercedes-benz&amp;model=e-class&amp;year=2020">More Inventory »</a>
                                    <div id="similar-cars" class="clear">
                                                <ul>
                                                                                                                                                                                                            <div class="section-title"> Similar Cars</div>
                                                                                                            <li>
                                        <a class="image-link" href="/overview/bmw_8-series_2020" title="2020 BMW 8-Series review">
                                            <img class="fitfill" src="https://images.hgmsites.net/sml/2020-bmw-8-series_100731077_s.jpg" alt="2020 BMW M8 " onerror="this.src='/images/noimage.gif'"/>                                        </a>
                                        <a href="/overview/bmw_8-series_2020">2020 BMW 8-Series</a>
                                    </li>
                                                                                                                                                                                                                                        <li>
                                        <a class="image-link" href="/overview/ram_2500_2020" title="2020 Ram 2500 review">
                                            <img class="fitfill" src="https://images.hgmsites.net/sml/2020-ram-2500_100713782_s.jpg" alt="2020 Ram 2500 " onerror="this.src='/images/noimage.gif'"/>                                        </a>
                                        <a href="/overview/ram_2500_2020">2020 Ram 2500</a>
                                    </li>
                                                                                                                            </ul>
                    </div>
                                <div id="email-subscribe-bottom" class="make-model-news-subscription">
                    <div class="email-form">
                        <div class="email-form-label">Sign up for email updates <br />
                            <span>Get updates about this model emailed to you</span>
                        </div>
                        <form onsubmit="return false;">
                            <input type="text" name="email"  class="subscription-email" placeholder="Email Address" />
                            <input type="hidden" name="type" value="tcc_new" class="subscription-type" />
                            <input type="hidden" name="make" value="mercedes-benz" />
                            <input type="hidden" name="model" value="e-class" />
                            <a href="/subscribe/addnew/" class="btn">Get Updates</a>
                        </form>
                    </div>
                    <div class="email-message"></div>
                    <div class="email-consent">
                        I agree to receive emails from The Car Connection. I understand that I can unsubscribe at any time. <a href="https://www.internetbrands.com/privacy/privacy-main.html" target="_blank">Privacy Policy.</a>
                    </div>
                </div>
            </div>
        </div>

         <!-- center column 200px -->
        <div id="center-column">
            <div id="other-models">
    <div class="title">Looking for other models of the Mercedes-Benz E Class?</div>
    <a href="/cars/mercedes-benz_e-class">Read reviews &amp; get prices</a>
</div>            <div id="sponsored-content">&nbsp;</div>
            
<div class="module other-choices">
    <div class="title">
                    Compare the 2020 Mercedes-Benz E Class against the competition
            </div>
    <ul>
                    <li>
                <div class="photo-box">
                    <a class="photo-wrapper" href="/overview/audi_a6_2020">
                        <img src="https://images.hgmsites.net/sml/2020-audi-a6_100728598_s.jpg" alt="2020 Audi A6" onerror="this.src='/images/noimage.gif'" width="200" height="133"/>                    </a>
                </div>
                                    <div class="name-dial">
                        <h3>
                            <a href="/overview/audi_a6_2020">2020 Audi A6</a>
                        </h3>
                        <style>
    .dial-value-70-animation::before {
        animation: dial-value-70 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-70 {
                    47.618047619048% {
                border-right-color: transparent;
            }
            47.619047619048% {
                border-right-color: #7DBC13;
            }
                            95.237095238095% {
                border-top-color: transparent;
            }
            95.238095238095% {
                border-top-color: #7DBC13;
            }
                100% {
            border-top-color: #7DBC13;
            border-right-color: #7DBC13;
            transform: rotate(189deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-70">
        <span class="ratingNumber">7.0</span>
    </div>
    <div class="dial-label"></div>
</div>
<script>
    $(function () {
        $('.dial-value-70').addClass('dial-value-70-animation');
    });
</script>
                    </div>
                                        <a class="btn" href="/car-compare-results/audi_a6_2020-vs-mercedes-benz_e-class_2020">Compare Cars</a>
                            </li>
                    <li>
                <div class="photo-box">
                    <a class="photo-wrapper" href="/overview/bmw_5-series_2020">
                        <img src="https://images.hgmsites.net/sml/2020-bmw-5-series_100729725_s.jpg" alt="2020 BMW 5-Series" onerror="this.src='/images/noimage.gif'" width="200" height="133"/>                    </a>
                </div>
                                    <div class="name-dial">
                        <h3>
                            <a href="/overview/bmw_5-series_2020">2020 BMW 5-Series</a>
                        </h3>
                        <style>
    .dial-value-73-animation::before {
        animation: dial-value-73 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-73 {
                    45.661100456621% {
                border-right-color: transparent;
            }
            45.662100456621% {
                border-right-color: #7DBC13;
            }
                            91.323200913242% {
                border-top-color: transparent;
            }
            91.324200913242% {
                border-top-color: #7DBC13;
            }
                100% {
            border-top-color: #7DBC13;
            border-right-color: #7DBC13;
            transform: rotate(197.1deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-73">
        <span class="ratingNumber">7.3</span>
    </div>
    <div class="dial-label"></div>
</div>
<script>
    $(function () {
        $('.dial-value-73').addClass('dial-value-73-animation');
    });
</script>
                    </div>
                                        <a class="btn" href="/car-compare-results/bmw_5-series_2020-vs-mercedes-benz_e-class_2020">Compare Cars</a>
                            </li>
                    <li>
                <div class="photo-box">
                    <a class="photo-wrapper" href="/overview/jaguar_xf_2020">
                        <img title="Angular Front Exterior View - 2020 Jaguar XF Sedan 25t Premium RWD" src="https://images.hgmsites.net/sml/2020-jaguar-xf-sedan-25t-premium-rwd-angular-front-exterior-view_100715776_s.jpg" alt="2020 Jaguar XF Sedan 25t Premium RWD Angular Front Exterior View" onerror="this.src='/images/noimage.gif'" width="200" height="150"/>                    </a>
                </div>
                                    <div class="name-dial">
                        <h3>
                            <a href="/overview/jaguar_xf_2020">2020 Jaguar XF</a>
                        </h3>
                                            </div>
                                        <a class="btn" href="/car-compare-results/jaguar_xf_2020-vs-mercedes-benz_e-class_2020">Compare Cars</a>
                            </li>
                    <li>
                <div class="photo-box">
                    <a class="photo-wrapper" href="/overview/lexus_gs_2020">
                        <img src="https://images.hgmsites.net/sml/2019-lexus-gs_100681879_s.jpg" alt="2019 Lexus GS" onerror="this.src='/images/noimage.gif'" width="200" height="133"/>                    </a>
                </div>
                                    <div class="name-dial">
                        <h3>
                            <a href="/overview/lexus_gs_2020">2020 Lexus GS</a>
                        </h3>
                        <style>
    .dial-value-56-animation::before {
        animation: dial-value-56 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-56 {
                    59.52280952381% {
                border-right-color: transparent;
            }
            59.52380952381% {
                border-right-color: #7DBC13;
            }
                        100% {
            ;
            border-right-color: #7DBC13;
            transform: rotate(151.2deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-56">
        <span class="ratingNumber">5.6</span>
    </div>
    <div class="dial-label"></div>
</div>
<script>
    $(function () {
        $('.dial-value-56').addClass('dial-value-56-animation');
    });
</script>
                    </div>
                                        <a class="btn" href="/car-compare-results/lexus_gs_2020-vs-mercedes-benz_e-class_2020">Compare Cars</a>
                            </li>
                    <li>
                <div class="photo-box">
                    <a class="photo-wrapper" href="/overview/volvo_s90_2020">
                        <img src="https://images.hgmsites.net/sml/2020-volvo-s90_100726866_s.jpg" alt="2020 Volvo S90" onerror="this.src='/images/noimage.gif'" width="200" height="139"/>                    </a>
                </div>
                                    <div class="name-dial">
                        <h3>
                            <a href="/overview/volvo_s90_2020">2020 Volvo S90</a>
                        </h3>
                        <style>
    .dial-value-72-animation::before {
        animation: dial-value-72 1s 1 linear;
        animation-fill-mode: forwards;
        -webkit-backface-visibility: hidden;
        backface-visibility: hidden;
        -webkit-transform: translateZ(360);
    }

    @keyframes dial-value-72 {
                    46.295296296296% {
                border-right-color: transparent;
            }
            46.296296296296% {
                border-right-color: #7DBC13;
            }
                            92.591592592593% {
                border-top-color: transparent;
            }
            92.592592592593% {
                border-top-color: #7DBC13;
            }
                100% {
            border-top-color: #7DBC13;
            border-right-color: #7DBC13;
            transform: rotate(194.4deg);
        }
    }
</style>
<div class="dial-container dial-container-tiny">
    <div class="dial dial-tiny dial-value-72">
        <span class="ratingNumber">7.2</span>
    </div>
    <div class="dial-label"></div>
</div>
<script>
    $(function () {
        $('.dial-value-72').addClass('dial-value-72-animation');
    });
</script>
                    </div>
                                        <a class="btn" href="/car-compare-results/mercedes-benz_e-class_2020-vs-volvo_s90_2020">Compare Cars</a>
                            </li>
            </ul>
            <a id="compare-all" href="/compare/mercedes-benz_e-class_2020_choices" class="btn">Compare All Cars</a>
    </div>

<script>
    $('.photo-wrapper img.fitfill').imgFitFill({mode:'fill'});
</script>
        </div>
    </div>

    <div id="right-column">
        <!-- GPT ADS 300x250 code begin -->
<div id="ad-2" class="ad ad-t-r" style="max-width: 300px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-2');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-2') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
        <!-- GPT ADS 300x250 code begin -->
<div id="ad-3" class="ad ad-t-r" style="max-width: 300px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-3');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-3') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
    </div>
</div>
<script>
    var ymm='30010581';
</script>
<script type="text/javascript">
    //<![CDATA[
    $("#lead-image img.fitfill").imgFitFill({mode:'fill'});
    $("#similar-cars img.fitfill").imgFitFill({mode:'fill'});
    $("#previous-years-reviews img.fitfill").imgFitFill({mode:'fill'});
    $("#lead-image-no-qq img.fitfill").imgFitFill({mode:'fill'});
    $("#make-logo img.fitfill").imgFitFill({mode:'fill'});
    $("#two-columns .news-image img.fitfill").imgFitFill({mode:'fill'});

    //]]>
</script>
            <div>
    <div id="tcc3-footer" class="clear">
        <div class="footer-column">
            <ul class="footer-ul first">
                <li><a href="/new-cars">New Cars</a></li>
                <li><a href="/car-compare">Compare cars</a></li>
                <li><a href="/inventory/carsforsale">Cars For Sale</a></li>
                <li><a href="/inventory/trucks-for-sale">Trucks For Sale</a></li>
                <li><a href="/used-cars">Used Cars</a></li>
                <li><a href="/inventory/cheap-cars">Cheap Cars</a></li>
                <li><a href="/car-loans">Finance</a></li>
                <li><a href="/videos">Videos</a></li>
                <li><a href="/news">News</a></li>
                <li><a href="/tips">Advice</a></li>
            </ul>
            <ul class="footer-ul">
                <li><a href="/resources/">Resource Center</a></li>
                <li><a href="/aboutus">About Us</a></li>
                <li><a href="/how-we-rate">How We Rate Cars</a></li>
                <li><a href="https://connect.carsdirect.com" target="_blank">Buy Auto Leads</a></li>
                <li><a href="/contactus">Contact Us</a></li>
                <li><a href="https://www.internetbrands.com/privacy/privacy-main.html">Privacy Policy</a></li>
                <li><a href="https://www.internetbrands.com/privacy/privacy-contact-form.php">Do Not  Sell My Personal Information</a></li>
                <li><a href="https://www.internetbrands.com/ibterms/">Terms of Use</a></li>
                <li><a href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
            </ul>
           <!-- <ul class="footer-ul">
                <li><a href="/aboutus/press">Blog</a></li>
                <li><a href="/rss">RSS Feed</a></li>
                <li><a href="https://wrightsmedia.com/reprints/index.cfm?magid=3531" title="Reprints" target="_blank" rel="nofollow">Reprints</a></li>
            </ul> -->
        </div>

        <div id="footer-social-wrapper">
    <div id="footer-social-links">
        <div class="social-icons">
                            <a class="facebook" href="https://www.facebook.com/TheCarConnection" target="_blank"></a>
                                        <a class="twitter" href="https://www.twitter.com/CarConnection" target="_blank"></a>
                                                    <a class="instagram" href="https://www.instagram.com/thecarconnection/" target="_blank"></a>
                                        <a class="youtube" href="https://www.youtube.com/user/thecarconnection" target="_blank"></a>
            
            <a class="rss" href="/rss"><img src="/images/rss-icon-small.png"></a>
        </div>
    </div>
    <div class="clear"></div>
</div>
    </div>
    <div id="footer-copyright">
        <div>&copy;&nbsp;2020 The Car Connection. All Rights Reserved.
The Car Connection is published by <a href="//www.internetbrandsauto.com/">Internet Brands Automotive Group</a>&trade;.
Stock photography by <a href="//www.izmocars.com/stockphotograph">izmo, Inc.</a>
Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.
</div>
    </div>
</div>
<div class="footer-mobile"></div>
<script>
    $('.FooterMoreColumn .image-link img.fitfill').imgFitFill({mode:'fill'});
    $(hgm.addMobileSiteButton);
    $(document).ready(function() {
        // executes when HTML-Document is loaded and DOM is ready
        hgm.debug("READY = " + (new Date().getTime() - window.startTime) / 1000 + " sec");
    });

    $(window).load(function() {
        // executes when complete page is fully loaded, including all frames, objects and images
        hgm.debug("LOAD  =  " + (new Date().getTime() - window.startTime) / 1000 + " sec");
        setTimeout(function(){
            var t = performance.timing;
            hgm.debug("LOAD With Navigation Timing API = " + (t.loadEventEnd - t.navigationStart) / 1000 + " sec");
        }, 0);
    });
</script>
                    </div><!-- global-container -->
    </div>
    <!-- HGM scripts -->
<script type="text/javascript">
    

    if ($.browser.msie && $.browser.version === "7.0") {
        var ie_box = "<div class='ie6_message_wrapper'>    \n\
        <div class='ie6_message'>  <h3>You are using an old browser which this site does not support, please upgrade to a modern browser.</h3>\n\
        <a href='https://www.mozilla.com/en-US/firefox/new/' class='firefox'></a> \n\
        <a href='https://www.apple.com/safari/' class='safari'></a>\n\
        <a href='https://www.microsoft.com/windows/internet-explorer/default.aspx' class='explorer'></a>\n\
        <a href='https://www.opera.com/browser/' class='opera'></a>\n\<a href='https://www.google.com/chrome/index.html' class='chrome'></a>\n\
        </div></div>";
        $("body").prepend(ie_box);
    }
    
</script>
<script type="text/javascript">
    

    (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-XVB7W');
    
</script>
<script type="text/javascript" src="/js_cache/565102.js"></script><!-- HGM scripts end -->
<script type="text/javascript">
var _sf_startpt = window._sf_startpt || (new Date()).getTime();
var _sf_async_config={uid:22002,domain:"thecarconnection.com"};
_sf_async_config.sections = 'other';
(function() {
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('async', 'true');
    e.setAttribute('src', (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") + "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();
</script>
<script>
    dataLayer.push({'exelate_query':'p=258&g=78&j=0&make=mercedes-benz&model=e-class&carmodelyear=2020&newcar=1&pageurl=%2Foverview%2Fmercedes-benz_e-class_2020%3Futm_source%3Dfeedburner%26utm_medium%3Dfeed%26utm_campaign%3DFeed%253A%2BTheCarConnection-CarReviews%2B%2528The%2BCar%2BConnection%2B-%2BCar%2BReviews%2529&sitename=thecarconnection'});
</script>
<!-- Misc ad campaigns not needing physical space -->

<!-- Tmplt: ???? | Site: 77968 | 10.16.88.242 -->
    <!-- Nativo -->
<!-- Nativo end -->
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"135926741","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGBFXVAYWTQ9aVQcPH14PQkEMSgENWFgMBB9EDlld","queueTime":0,"applicationTime":215,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
