<!DOCTYPE html>
<html version="HTML+RDFa 1.0" xmlns:og="https://ogp.me/ns#" lang="en"
      data-site-id="40070"
      data-tmplt="77563"
      data-site="77563"
      data-addr="10.16.88.242"
      data-time="2019-08-16T02:26:17-0700"
      data-env="production"
      data-debug="false"
      data-layout="desktop"
>
<head>
    <script type='text/javascript' src='//cdn.districtm.ca/merge/all.ib.hg.js'></script>
        
<script>var _sf_startpt = (new Date()).getTime();</script>

<meta name="description" content="The 2020 Chevrolet Corvette costs less than $60,000 including destination, and the Z51 package adds $5,000." >

<meta charset="utf-8"><script type="text/javascript">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</script>
<meta property="fb:pages" content="14924137380" >
<meta property="fb:app_id" content="115451182597" >
<meta property="og:site_name" content="The Car Connection" >
<meta property="og:type" content="article" >
<meta property="og:title" content="2020 Chevrolet Corvette costs $59,995 to start, including fees" >
<meta property="og:url" content="https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees" >
<meta property="og:image" content="https://images.hgmsites.net/hug/2020-chevrolet-corvette_100708581_h.jpg" >
<meta property="og:description" content="The 2020 Chevrolet Corvette costs less than $60,000 including destination, and the Z51 package adds $5,000." >
<meta name="twitter:card" content="summary_large_image" >
<meta name="twitter:site" content="@CarConnection" >
<meta name="twitter:url" content="https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees" >
<meta name="twitter:title" content="2020 Chevrolet Corvette costs $59,995 to start, including fees" >
<meta name="twitter:description" content="The 2020 Chevrolet Corvette costs less than $60,000 including destination, and the Z51 package adds $5,000." >
<meta name="twitter:image" content="https://images.hgmsites.net/lrg/2020-chevrolet-corvette_100708581_l.jpg" >
<meta name="twitter:app:name:iphone" content="The Car Connection" >
<meta name="twitter:app:url:iphone" content="thecarconnection://open?article#1124589" >
<meta name="twitter:app:id:iphone" content="370081680" >
<meta name="twitter:app:name:ipad" content="The Car Connection" >
<meta name="twitter:app:url:ipad" content="thecarconnection://open?article#1124589" >
<meta name="twitter:app:id:ipad" content="370081680" >
<meta name="google-site-verification" content="V9IWZvYSmqTqLJdvv4KM5yUbzswzQb6XFcrgJCq-dWM" >
<meta name="y_key" content="b76b577d4b8c8d6a" >
<meta name="msvalidate.01" content="980788190813CA06E1A755281D49D247" ><title>2020 Chevrolet Corvette costs $59,995 to start, including fees</title><script type="application/ld+json">
{"@context":"https://schema.org","@type":"WebPage","@id":"https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees","url":"https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees","isPartOf":{"@type":"WebSite","@id":"https://www.thecarconnection.com/#site"},"breadcrumb":{"@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.thecarconnection.com/news","name":"News"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.thecarconnection.com/news/sport-cars","name":"Sports Cars"}}]},"mainEntity":{"@type":"NewsArticle","@id":"https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees#this","url":"https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees","headline":"2020 Chevrolet Corvette costs $59,995 to start, including fees","datePublished":"2019-08-15T12:00:00-0700","dateModified":"2019-08-15T11:38:27-0700","description":"The 2020 Chevrolet Corvette costs less than $60,000 including destination, and the Z51 package adds $5,000.","author":{"@type":"Person","name":"Aaron Cole","jobTitle":"Managing Editor","image":"https://images.hgmsites.net/tny/avatar-image-for-acole_100544845_0.jpg","url":"https://www.thecarconnection.com/writer/10057810_aaron-cole"},"publisher":{"@type":"Organization","@id":"https://www.thecarconnection.com/#organization"},"articleSection":"Sports Cars","keywords":"Sports Cars","image":{"@type":"ImageObject","@id":"https://images.hgmsites.net/lrg/2020-chevrolet-corvette_100708581_l.jpg#this","url":"https://images.hgmsites.net/lrg/2020-chevrolet-corvette_100708581_l.jpg","caption":"2020 Chevrolet Corvette Stingray","description":"","width":1024,"height":682,"uploadDate":"2019-07-18T21:40:19-0700"}}}
</script>
<script class="kxct" data-id="sh2lfhber" data-timing="async" data-version="3.0">
    window.Krux||((Krux=function(){Krux.q.push(arguments);}).q=[]);
    (function(){
        function retrieve(n){
            var k='kx'+'internetbrands_'+n, ls=(function(){
                try {
                    return window.localStorage;
                } catch(e) {
                    return null;
                }
            })();
            if (ls) {
                return ls[k] || '';
            } else if (navigator.cookieEnabled) {
                var m = document.cookie.match(k+'=([^;]*)');
                return (m && unescape(m[1])) || '';
            } else {
                return '';
            }
        }
        Krux.user = retrieve('user');
        Krux.segments = retrieve('segs').split(',');
        var k=document.createElement('script');k.type='text/javascript';k.async=true;
        k.src='https://cdn.krxd.net/controltag/sh2lfhber.js';
        var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(k,s);
    })();
</script>
<script async src="https://js-sec.indexww.com/ht/p/184397-109240026891666.js"></script>

<link href="https://feeds.feedburner.com/TheCarConnection-NewsAndBlogs" rel="alternate" type="application/rss+xml" title="The Car Connection News" >
<link href="https://feeds.feedburner.com/TheCarConnection-CarReviews" rel="alternate" type="application/rss+xml" title="The Car Connection Reviews" >
<link href="https://images.hgmsites.net/hug/2020-chevrolet-corvette_100708581_h.jpg" rel="image_src" >
<link href="https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees" rel="canonical" >
<link href="/favicon.ico" rel="shortcut icon" type="image/x-icon" >
<link href="/css_cache/555577.css" media="all" rel="stylesheet" type="text/css" ><!--<script src="/js/hgm/performance.js"></script>-->

<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js"></script>
<script type="text/javascript" src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.16/jquery-ui.min.js"></script>

<script src="https://cdn.optimizely.com/js/2803520120.js"></script>


<script type="text/javascript">
    
$(function () { hgm.social.fb.init('', null, '115451182597', false); });    
</script>
<script type="text/javascript">
    
$(function() { hgm.social.twttr.init('CarConnection'); });    
</script>
<script type="text/javascript" src="/js_cache/555551.js"></script>
<script type="text/javascript" src="/js_cache/555578.js"></script><script src="/ad.min.js"></script>
<script>
            (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
            m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-218811-12', 'auto');
                    // Optimizely Universal Analytics Integration Code
            window.optimizely = window.optimizely || [];
            window.optimizely.push("activateUniversalAnalytics");
            // End Optimizely Code
                ga('set', 'dimension1', 'Desktop');
        ga('set', 'dimension3', typeof sadfq2v3raesxf2dxx3r2348 == 'undefined' ? 'Blocker Enabled' : 'No Blocker');

        ga('set', 'dimension4',  (typeof disabledPixel == 'undefined'  || disabledPixel == '') ? 'No Pixel Blocked' : disabledPixel + ' Blocked');
                    ga('send', 'pageview');
            
    var _gaq = _gaq || [];
    _gaq.push(
        ['_setAccount', 'UA-218811-1'],
        // FIXME This doesn't take preview flag into account which may affect isPageMobile() result
        ['_setCustomVar', 1, 'Template', 'Desktop', 3],
        ['_setCustomVar', 3, 'Blocker Enabled', typeof sadfq2v3raesxf2dxx3r2348 == 'undefined' ? 'Yes' : 'No', 3],
        ['_setCustomVar', 4, 'Disabled Pixel ', (typeof disabledPixel == 'undefined' || disabledPixel == '') ? 'None' : disabledPixel, 3],
                    ['_trackPageview' ]
            );
    (function() {
        var ga = document.createElement('script');
        ga.type = 'text/javascript';
        ga.async = true;
        // ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
        ga.src = 'https://stats.g.doubleclick.net/dc.js';
        document.documentElement.firstChild.appendChild(ga);
    }());
</script>
<script>
    var axel = Math.random() + "";
    var ord = axel * 1000000000000000000;
</script>
<!--[if lt IE 9 ]>
<link rel="stylesheet" type="text/css" href="/css/ie7+.css"/>
<![endif]-->
<!-- Google Publisher Tags - TCC-992 -->
<script src="//internetbrands-d.openx.net/w/1.0/jstag?nc=2922-TheCarConnection"></script><!-- Start: GPT Async -->
<script>
    var gptadslots = [],
        apstagslots = [],
        googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function(){
        var gads = document.createElement('script');
        var useSSL = 'https:' === document.location.protocol;
        gads.async = true;
        gads.type = 'text/javascript';
        gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
        var node = document.getElementsByTagName('script')[0];
        node.parentNode.insertBefore(gads, node);
    })();
</script><script>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</script>
<!-- End: GPT --><script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function()
    {q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];
        g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

    // initialize apstag and have apstag set bids on the googletag slots when they are returned to the page  
    apstag.init({    
        pubID:'3188',    
        adServer:'googletag',    
        bidTimeout:2e3
    });

//apstag.debug('anable');

    // request the bids for the four googletag slots  
googletag.cmd.push(function() {
    apstag.fetchBids({    
        slots: apstagslots
    },function(bids){
        hgm.debug("apstag request for the apstag :", bids);
        // trigger the first request to DFP 
        googletag.cmd.push(function(){  
            apstag.setDisplayBids();        });
    });
});
</script></head>
<body>
    <script>
    // Google Tag Manager data
    dataLayer = [];
            dataLayer.push({"year_id":"30010445","year_seo_name":"2020","year_name":"2020","year":"2020","model_id":"20000087","model_seo_name":"corvette","model_name":"Corvette","model":"corvette","body_style":"2-doors","vcat":"2-doors","make_id":"10006","make_seo_name":"chevrolet","make_name":"Chevrolet","make":"chevrolet","enable_inline_ads":true});
        if (typeof disabledPixel !== 'undefined') {
        dataLayer.push({'pixelToDisable': disabledPixel});
    }
</script>
<!-- 0.9000301361084ms -->
    <div id="body-inner">
                    <!-- Begin comScore Tag -->
    <script>
        var COMSCORE_CLIENT_ID = '7533348',
            _comscore = _comscore || [];

        _comscore.push({ c1: "2", c2: "7533348" });
        (function() {
            var s = document.createElement("script"),
                el = document.getElementsByTagName("script")[0];
            s.async = true;
            s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
            el.parentNode.insertBefore(s, el);
        })();
    </script>
    <noscript>
        <img src="https://sb.scorecardresearch.com/p?c1=2&amp;c2=7533348&amp;c3=&amp;c4=&amp;c5=&amp;c6=&amp;c15=&amp;cj=1" />
    </noscript>
    <!-- End comScore Tag -->        <script type="text/javascript">
    window.startTime = new Date().getTime();
</script>
<nav id="top-nav">
    <!-- The Car Connection -->
    <div id="nav-main">
        <a id="header-logo"  href="/" title="The Car Connection">The Car Connection</a>
        
<div id="primary-nav">
    <a class="menu-item dd" data-id="new" href="/new-cars">New Cars<span class="line"></span></a>
    <a class="menu-item dd" data-id="used" href="/used-cars">Used Cars<span class="line"></span></a>
    <a class="menu-item dd" data-id="research" href="/rankings">Research<span class="line"></span></a>
    <a class="menu-item" href="/videos">Videos<span class="line"></span></a>
    <a class="menu-item" href="/news">News<span class="line"></span></a>
            <a class="menu-item dd" data-id="finance" href="/car-loans/">Auto Finance<span class="line"></span></a>
        <div class="menu-window" id="new-window" style="display:none;">
        <div class="module make-container">
    <h3>Research New Cars By Make</h3>
        <div class="menu-column" data-column="0">
                                                    <a href="/make/new,acura" title="Acura" data-seo="acura">Acura</a>
                                                            <a href="/make/new,alfa-romeo" title="Alfa Romeo" data-seo="alfa-romeo">Alfa Romeo</a>
                                                            <a href="/make/new,aston-martin" title="Aston Martin" data-seo="aston-martin">Aston Martin</a>
                                                            <a href="/make/new,audi" title="Audi" data-seo="audi">Audi</a>
                                                            <a href="/make/new,bentley" title="Bentley" data-seo="bentley">Bentley</a>
                                                            <a href="/make/new,bmw" title="BMW" data-seo="bmw">BMW</a>
                                                            <a href="/make/new,buick" title="Buick" data-seo="buick">Buick</a>
                                                            <a href="/make/new,cadillac" title="Cadillac" data-seo="cadillac">Cadillac</a>
                                                            <a href="/make/new,chevrolet" title="Chevrolet" data-seo="chevrolet">Chevrolet</a>
                                                            <a href="/make/new,chrysler" title="Chrysler" data-seo="chrysler">Chrysler</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="1">
                                                            <a href="/make/new,dodge" title="Dodge" data-seo="dodge">Dodge</a>
                                                                                <a href="/make/new,ferrari" title="Ferrari" data-seo="ferrari">Ferrari</a>
                                                            <a href="/make/new,fiat" title="FIAT" data-seo="fiat">FIAT</a>
                                                            <a href="/make/new,ford" title="Ford" data-seo="ford">Ford</a>
                                                            <a href="/make/new,genesis" title="Genesis" data-seo="genesis">Genesis</a>
                                                            <a href="/make/new,gmc" title="GMC" data-seo="gmc">GMC</a>
                                                            <a href="/make/new,honda" title="Honda" data-seo="honda">Honda</a>
                                                            <a href="/make/new,hyundai" title="Hyundai" data-seo="hyundai">Hyundai</a>
                                                            <a href="/make/new,infiniti" title="INFINITI" data-seo="infiniti">INFINITI</a>
                                                            <a href="/make/new,jaguar" title="Jaguar" data-seo="jaguar">Jaguar</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="2">
                                                            <a href="/make/new,jeep" title="Jeep" data-seo="jeep">Jeep</a>
                                                            <a href="/make/new,kia" title="Kia" data-seo="kia">Kia</a>
                                                                                <a href="/make/new,lamborghini" title="Lamborghini" data-seo="lamborghini">Lamborghini</a>
                                                            <a href="/make/new,land-rover" title="Land Rover" data-seo="land-rover">Land Rover</a>
                                                            <a href="/make/new,lexus" title="Lexus" data-seo="lexus">Lexus</a>
                                                            <a href="/make/new,lincoln" title="Lincoln" data-seo="lincoln">Lincoln</a>
                                                            <a href="/make/new,maserati" title="Maserati" data-seo="maserati">Maserati</a>
                                                            <a href="/make/new,mazda" title="Mazda" data-seo="mazda">Mazda</a>
                                                            <a href="/make/new,mclaren" title="McLaren" data-seo="mclaren">McLaren</a>
                                                            <a href="/make/new,mercedes-benz" title="Mercedes-Benz" data-seo="mercedes-benz">Mercedes-Benz</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="3">
                                                            <a href="/make/new,mini" title="MINI" data-seo="mini">MINI</a>
                                                            <a href="/make/new,mitsubishi" title="Mitsubishi" data-seo="mitsubishi">Mitsubishi</a>
                                                            <a href="/make/new,nissan" title="Nissan" data-seo="nissan">Nissan</a>
                                                                                <a href="/make/new,porsche" title="Porsche" data-seo="porsche">Porsche</a>
                                                            <a href="/make/new,ram" title="Ram" data-seo="ram">Ram</a>
                                                            <a href="/make/new,rolls-royce" title="Rolls-Royce" data-seo="rolls-royce">Rolls-Royce</a>
                                                            <a href="/make/new,smart" title="smart" data-seo="smart">smart</a>
                                                            <a href="/make/new,subaru" title="Subaru" data-seo="subaru">Subaru</a>
                                                            <a href="/make/new,tesla" title="Tesla" data-seo="tesla">Tesla</a>
                                                            <a href="/make/new,toyota" title="Toyota" data-seo="toyota">Toyota</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="4">
                                                            <a href="/make/new,volkswagen" title="Volkswagen" data-seo="volkswagen">Volkswagen</a>
                                                            <a href="/make/new,volvo" title="Volvo" data-seo="volvo">Volvo</a>
                                        </div>
</div>
        <div class="type-container module">
    <h3>Research By Category</h3>
        <a href="/category/new,convertible" class="car-name-standard ">Convertibles</a>

            <a href="/category/new,coupes" class="car-name-standard ">Coupes</a>

            <a href="/category/new,crossover" class="car-name-standard ">Crossovers</a>

            <a href="/category/new,electric-car" class="car-name-standard ">Electric Cars</a>

            <a href="/category/new,hatchback" class="car-name-standard ">Hatchbacks</a>

            <a href="/category/new,hybrid" class="car-name-standard last">Hybrids</a>

            <div class="spacer"></div>
            <a href="/category/new,luxury" class="car-name-standard ">Luxury Cars</a>

            <a href="/category/new,minivans-sub" class="car-name-standard ">Minivans</a>

            <a href="/category/new,pickups" class="car-name-standard ">Pickup Trucks</a>

            <a href="/category/new,suvs" class="car-name-standard ">SUVs</a>

            <a href="/category/new,sedans" class="car-name-standard ">Sedans</a>

            <a href="/category/new,wagons" class="car-name-standard last">Wagons</a>

        </div> <!-- module -->
        <a href="/new-cars" class="extra-link larger">Research New Cars &raquo;</a>
    </div>
    <div class="menu-window" id="used-window" style="display:none;">
        <div class="module make-container">
    <h3>Used Cars For Sale Near You</h3>
        <div class="menu-column" data-column="0">
                                                    <a href="/make/used,acura" title="Acura" data-seo="acura">Acura</a>
                                                            <a href="/make/used,alfa-romeo" title="Alfa Romeo" data-seo="alfa-romeo">Alfa Romeo</a>
                                                            <a href="/make/used,am-general" title="AM General" data-seo="am-general">AM General</a>
                                                            <a href="/make/used,aston-martin" title="Aston Martin" data-seo="aston-martin">Aston Martin</a>
                                                            <a href="/make/used,audi" title="Audi" data-seo="audi">Audi</a>
                                                            <a href="/make/used,bentley" title="Bentley" data-seo="bentley">Bentley</a>
                                                            <a href="/make/used,bmw" title="BMW" data-seo="bmw">BMW</a>
                                                            <a href="/make/used,buick" title="Buick" data-seo="buick">Buick</a>
                                                            <a href="/make/used,cadillac" title="Cadillac" data-seo="cadillac">Cadillac</a>
                                                            <a href="/make/used,chevrolet" title="Chevrolet" data-seo="chevrolet">Chevrolet</a>
                                                            <a href="/make/used,chrysler" title="Chrysler" data-seo="chrysler">Chrysler</a>
                                                            <a href="/make/used,dodge" title="Dodge" data-seo="dodge">Dodge</a>
                                                                                <a href="/make/used,ferrari" title="Ferrari" data-seo="ferrari">Ferrari</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="1">
                                                            <a href="/make/used,fiat" title="FIAT" data-seo="fiat">FIAT</a>
                                                            <a href="/make/used,ford" title="Ford" data-seo="ford">Ford</a>
                                                            <a href="/make/used,genesis" title="Genesis" data-seo="genesis">Genesis</a>
                                                            <a href="/make/used,gmc" title="GMC" data-seo="gmc">GMC</a>
                                                            <a href="/make/used,honda" title="Honda" data-seo="honda">Honda</a>
                                                            <a href="/make/used,hummer" title="HUMMER" data-seo="hummer">HUMMER</a>
                                                            <a href="/make/used,hyundai" title="Hyundai" data-seo="hyundai">Hyundai</a>
                                                            <a href="/make/used,infiniti" title="INFINITI" data-seo="infiniti">INFINITI</a>
                                                            <a href="/make/used,jaguar" title="Jaguar" data-seo="jaguar">Jaguar</a>
                                                            <a href="/make/used,jeep" title="Jeep" data-seo="jeep">Jeep</a>
                                                            <a href="/make/used,kia" title="Kia" data-seo="kia">Kia</a>
                                                                                <a href="/make/used,lamborghini" title="Lamborghini" data-seo="lamborghini">Lamborghini</a>
                                                            <a href="/make/used,land-rover" title="Land Rover" data-seo="land-rover">Land Rover</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="2">
                                                            <a href="/make/used,lexus" title="Lexus" data-seo="lexus">Lexus</a>
                                                            <a href="/make/used,lincoln" title="Lincoln" data-seo="lincoln">Lincoln</a>
                                                            <a href="/make/used,lotus" title="Lotus" data-seo="lotus">Lotus</a>
                                                            <a href="/make/used,maserati" title="Maserati" data-seo="maserati">Maserati</a>
                                                            <a href="/make/used,mazda" title="Mazda" data-seo="mazda">Mazda</a>
                                                            <a href="/make/used,mclaren" title="McLaren" data-seo="mclaren">McLaren</a>
                                                            <a href="/make/used,mercedes-benz" title="Mercedes-Benz" data-seo="mercedes-benz">Mercedes-Benz</a>
                                                            <a href="/make/used,mini" title="MINI" data-seo="mini">MINI</a>
                                                            <a href="/make/used,mitsubishi" title="Mitsubishi" data-seo="mitsubishi">Mitsubishi</a>
                                                            <a href="/make/used,nissan" title="Nissan" data-seo="nissan">Nissan</a>
                                                                                <a href="/make/used,porsche" title="Porsche" data-seo="porsche">Porsche</a>
                                                            <a href="/make/used,ram" title="Ram" data-seo="ram">Ram</a>
                                                            <a href="/make/used,rolls-royce" title="Rolls-Royce" data-seo="rolls-royce">Rolls-Royce</a>
                                                        </div><!-- close menu-column -->
                    <div class="menu-column" data-column="3">
                                                            <a href="/make/used,saturn" title="Saturn" data-seo="saturn">Saturn</a>
                                                            <a href="/make/used,scion" title="Scion" data-seo="scion">Scion</a>
                                                            <a href="/make/used,smart" title="smart" data-seo="smart">smart</a>
                                                            <a href="/make/used,subaru" title="Subaru" data-seo="subaru">Subaru</a>
                                                            <a href="/make/used,tesla" title="Tesla" data-seo="tesla">Tesla</a>
                                                            <a href="/make/used,toyota" title="Toyota" data-seo="toyota">Toyota</a>
                                                            <a href="/make/used,volkswagen" title="Volkswagen" data-seo="volkswagen">Volkswagen</a>
                                                            <a href="/make/used,volvo" title="Volvo" data-seo="volvo">Volvo</a>
                                        </div>
</div>
        <div class="type-container module">
    <h3>Used Cars by Category</h3>
        <a href="/category/used,convertible" class="car-name-standard ">Convertibles</a>

            <a href="/category/used,coupes" class="car-name-standard ">Coupes</a>

            <a href="/category/used,crossover" class="car-name-standard ">Crossovers</a>

            <a href="/category/used,electric-car" class="car-name-standard ">Electric Cars</a>

            <a href="/category/used,hatchback" class="car-name-standard ">Hatchbacks</a>

            <a href="/category/used,hybrid" class="car-name-standard last">Hybrids</a>

            <div class="spacer"></div>
            <a href="/category/used,luxury" class="car-name-standard ">Luxury Cars</a>

            <a href="/category/used,minivans-sub" class="car-name-standard ">Minivans</a>

            <a href="/category/used,pickups" class="car-name-standard ">Pickup Trucks</a>

            <a href="/category/used,suvs" class="car-name-standard ">SUVs</a>

            <a href="/category/used,sedans" class="car-name-standard ">Sedans</a>

            <a href="/category/used,wagons" class="car-name-standard last">Wagons</a>

        </div> <!-- module -->
        <a href="/used-cars" class="extra-link larger">Browse Used Cars For Sale &raquo;</a>
    </div>
    <div class="menu-window clear" id="research-window" style="display:none;">
        <div class="column">
            <h3>Reviews</h3>
            <a href="/news/compare" title="Head To Head Compare Reviews">Head to Head</a>
            <a href=" /news/first-drives" title="First Drive Reviews">First Drives </a>
            <a href="/news/video-reviews" title="Video Reviews">Video Reviews</a>
            <a class="see-all" href="/reviews" title="Read All Reviews">All Reviews &#187;</a>
        </div>
        <div class="column">
            <h3>Rankings</h3>
                                            <a href="/rankings/cars" title="Cars" >
                    Cars                </a>
                                <a href="/rankings/suvs" title="SUVs" >
                    SUVs                </a>
                                <a href="/rankings/trucks" title="Trucks" >
                    Trucks                </a>
                                <a href="/rankings/vans" title="Vans/Minivans" >
                    Vans/Minivans                </a>
                                <a href="/rankings/hybrids-electrics" title="Hybrids/Electrics" >
                    Hybrids/Electrics                </a>
                                <a class="see-all" title="TCC Top Ranked Cars" href="/rankings">All Rankings &#187;</a>
        </div>
        <div class="column">
            <h3>Advice</h3>
            <a href="/car-compare">Compare Cars</a>
                            <a href="/advice/buying-guides" title="Buying Guides">Buying Guides</a>
                            <a href="/advice/maintenance" title="Maintenance Guides">Maintenance Guides</a>
                            <a href="/advice/finance" title="Finance Guides">Finance Guides</a>
                            <a href="/advice/the-basics" title="The Basics">The Basics</a>
                        <a class="see-all" href="/tips" title="The Basics">All Advice &#187;</a>
        </div>
        <div class="column last">
            <h3>Awards</h3>
                            <a id="bctb" href="/bestcartobuy/2019" title="Check Our Best Car to Buy 2019">Best Car to Buy <span>2019</span>&nbsp;&raquo;</a>
                                        <a id="dc" href="/driverschoice/2019" title="Check Driver's Choice 2019">Driver's Choice <span>2019</span>&nbsp;&raquo;</a>
                    </div>
    </div>
    <div class="menu-window" id="finance-window" style="display:none;">
        <div class="column">
            <a href="/car-loans/apply/" title="Apply For Car Loan" class="extra-link">Start a Loan Request Form Today!</a>
            <a href="/car-loans/finance-guides/" title="Get Car Financing Advice">Car Financing Advice</a>
            <a href="/resources/" title="Access Car Financing Resources">Resource Center</a>
            <a href="/car-loans/payment-calculator/" title="Calculate Monthly Payments">Monthly Payment Calculator</a>
            <a href="/car-loans/loan-estimator/" title="Estimate Car Loan">Car Loan Estimator</a>
        </div>
    </div>
</div>
<div id="masterSearch">
    <div class="global-google-search" id="google-search-form-0" style="width: 210px;">

    <script>
        (function() {
            var cx = '001937828977938864696:wubol2i6jwo';
            var gcse = document.createElement('script');
            gcse.type = 'text/javascript';
            gcse.async = true;
            gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
            var s = document.getElementsByTagName('script')[0];
            s.parentNode.insertBefore(gcse, s);
        })();
    </script>
    <gcse:searchbox-only resultsUrl="/searchresults"></gcse:searchbox-only>
    
<!-- Google CSE Search Box Begins  -->
<!-- Google CSE Search Box Ends -->
</div>
</div>
    </div>
</nav>
<div id="top-ad-with-breadcrumbs">
    <div id="banner-container">
        <div style="width:728px;height:90px;margin: 0 auto;">
                            <!-- GPT ADS 728x90 code begin -->
<div id="ad-1" class="ad ad-r-t" style="max-width: 728px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-1');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-1') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
                    </div>
    </div>
    <div id="top-toolbar-container">
        <div id="top-toolbar">
                                        <div id="simple-crumbs">
                <a href="/">Home</a><a href="/news">News</a><a href="/news/sport-cars">Sports Cars</a>
            </div>
                            </div>
    </div>
</div>
        <div id="tcc3-global-container">
            <script>
    dataLayer.push({'category_tags': 'coupes,2020,corvette,chevrolet,news,sport-cars',
                    'tags': 'coupes,2020,corvette,chevrolet,news,sport-cars'});
</script>
<div>
    <div class="compare-banner"></div>
    <h1 class="headline">2020 Chevrolet Corvette costs $59,995 to start, including fees</h1>
    <div id="content">
                <div id="main-column">
                            <div class="gallery-container">
    <!-- gallery 705px -->
        <script id="hgm_photo_GalleryTemplate" type="text/x-ejs-template">
    <div class="swiper-container">
        <div class="swiper-wrapper">
        [% var desc = this.showDescription %]
            [% $.each(this.gallery, function (idx, imageObj) { %]
                <div class="swiper-slide" data-hash="[%= idx + 1 %]">
                    [% if (desc === true) { %]
                        <div class="image-desc">[%= imageObj.title %]</div>
                    [% } %]
                    <div class="image"
                    [% $.each(imageObj.images, function (idx, image) { %]
                        data-image-[%= idx %]="[%= image.url %]"
                    [% }); %]
                        data-width="[%= imageObj.images.small.width %]" data-height="[%= imageObj.images.small.height %]"
                        data-index="[%= idx %]">
                    </div>
                    <div class="modalSpinner"></div>
                </div>
            [% }); %]
        </div>
        <div class="modalNav modalNavBottom">
            <div class="modalPlay"></div>
        </div> 
        <div class="gallery-nav left icon-arrow-left"></div>
        <div class="gallery-nav right icon-arrow-right"></div>   
    </div>
</script>
<div class="swipe-gallery has-thumbnails">
    <div
        class="gallery"
        data-id="1124589"
        data-url="/pictures/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees_gallery-1"
        data-zone="slider"
        data-show-title="1"
        data-show-count="1"
        data-slideshow="1"
        data-show-fullscreen="1"
        data-portrait-height="553px"
        data-landscape-height="250px"
        data-show-view-type=""
        data-view-type=""
        data-yrmd-json=""
        data-controller=""
        
                style="width: 905px; height: 553px"
                    data-model="[{&quot;id&quot;:&quot;100708581&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708581_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708581_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708581_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708581_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708581_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708582&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708582_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708582_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708582_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708582_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708582_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708591&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708591_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708591_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708591_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708591_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708591_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708590&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708590_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708590_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708590_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708590_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708590_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708589&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708589_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708589_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708589_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708589_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708589_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708588&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708588_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708588_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708588_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708588_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708588_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708587&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708587_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708587_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:191},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708587_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:382},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708587_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:611},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708587_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1146}}},{&quot;id&quot;:&quot;100708586&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708586_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708586_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708586_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708586_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708586_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708585&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708585_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708585_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:480},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708585_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:960},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708585_l.jpg&quot;,&quot;width&quot;:853,&quot;height&quot;:1280},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708585_l.jpg&quot;,&quot;width&quot;:853,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708584&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708584_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708584_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:480},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708584_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:960},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708584_l.jpg&quot;,&quot;width&quot;:853,&quot;height&quot;:1280},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708584_l.jpg&quot;,&quot;width&quot;:853,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708583&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708583_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708583_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:480},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708583_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:960},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708583_l.jpg&quot;,&quot;width&quot;:853,&quot;height&quot;:1280},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708583_l.jpg&quot;,&quot;width&quot;:853,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708578&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708578_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708578_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:205},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708578_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:411},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708578_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:658},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708578_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1235}}},{&quot;id&quot;:&quot;100708577&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708577_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708577_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708577_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708577_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708577_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}},{&quot;id&quot;:&quot;100708576&quot;,&quot;title&quot;:&quot;2020 Chevrolet Corvette Stingray&quot;,&quot;description&quot;:&quot;&quot;,&quot;isExt&quot;:false,&quot;isInt&quot;:false,&quot;images&quot;:{&quot;thumb&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/tmb\/2020-chevrolet-corvette_100708576_t.gif&quot;,&quot;width&quot;:90,&quot;height&quot;:60},&quot;small&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/sml\/2020-chevrolet-corvette_100708576_s.jpg&quot;,&quot;width&quot;:320,&quot;height&quot;:213},&quot;medium&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/med\/2020-chevrolet-corvette_100708576_m.jpg&quot;,&quot;width&quot;:640,&quot;height&quot;:426},&quot;large&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/lrg\/2020-chevrolet-corvette_100708576_l.jpg&quot;,&quot;width&quot;:1024,&quot;height&quot;:682},&quot;huge&quot;:{&quot;url&quot;:&quot;https:\/\/images.hgmsites.net\/hug\/2020-chevrolet-corvette_100708576_h.jpg&quot;,&quot;width&quot;:1920,&quot;height&quot;:1280}}}]"
            ><!-- .gallery -->

                    <a href="/pictures/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees_gallery-1" class="lead-image">
                <img class="fitfill" src="https://images.hgmsites.net/med/2020-chevrolet-corvette_100708581_m.jpg" alt="2020 Chevrolet Corvette Stingray" onerror="this.src='/images/listings-no-images.jpg'"/>                    </a>
            </div>
    <!-- /.gallery -->
                <div class="thumbnails" data-skip-thumbnails="1">
    <div class="thumbs-nav-left"><div class="icon"></div></div>
    <div class="thumbs-container">
        <div class="thumbs-wrapper">
                                                            <div class="thumbs-slide thumb-active">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708581_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708582_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708591_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708590_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708589_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708588_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708587_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708586_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708585_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708584_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708583_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708578_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708577_t.gif"/>
                    </div>
                                    <div class="thumbs-slide ">
                        <img src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708576_t.gif"/>
                    </div>
                                    </div>
    </div>
    <div class="thumbs-nav-right"><div class="icon"></div></div>
</div>



    </div>
<script>
    if (hgm.isMobileView()) {
        $(function () {
            $('.swipe-gallery img.fitfill').imgFitFill({mode:'fill'});
        });
    }
    else {
        $('img.fitfill').imgFitFill({mode:'fill'});
    }
</script>

        </div>

<!-- center column 200px -->
<div id="center-column">
    <div class="byline">
            <div class="reviewer">
            <img class="author-portrait" src="https://images.hgmsites.net/sml/avatar-image-for-acole_100544845_s.jpg" alt="Aaron Cole" width="45" height="45"/>            <a class="author-link softBlue" href="/writer/10057810_aaron-cole">
                <span>Aaron Cole</span>
            </a>
            <span>Managing Editor</span>
        </div>
    </div>
    <script>
    function popupCenter(pageURL, w, h) {
        var left = (screen.width/2)-(w/2);
        var top = (screen.height/2)-(h/2);
        var targetWin = window.open (pageURL, 'sociallinks', 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width='+w+', height='+h+', top='+top+', left='+left);
        return false;
    }
    $('.social .email-this').live('click', showSocialEmailForm);
</script>
<div class="social">
    <ul>

        <li class="social-twitter-button">
            <a title="Share this article on Twitter"
                href="javascript:void(0);" data-title="News%3A%202020%20Chevrolet%20Corvette%20costs%20%2459%2C995%20to%20start%2C%20including%20fees"
                onclick="hgm.trackEvent('Social Buttons Vertical', 'Twitter Button Clicked');popupCenter('https://twitter.com/home?status=News%3A%202020%20Chevrolet%20Corvette%20costs%20%2459%2C995%20to%20start%2C%20including%20fees https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees', 700, 300)">
            </a>
        </li>
        <li class="social-facebook-button">
            <a class="facebook" title="Share this article on Facebook"
               href="javascript:void(0);" data-title="News%3A%202020%20Chevrolet%20Corvette%20costs%20%2459%2C995%20to%20start%2C%20including%20fees"
               onclick="hgm.trackEvent('Social Buttons Vertical', 'Facebook Button Clicked');popupCenter('https://www.facebook.com/sharer.php?t=News%3A%202020%20Chevrolet%20Corvette%20costs%20%2459%2C995%20to%20start%2C%20including%20fees&amp;u=https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees', 700, 400)">
            </a>
        </li>
        <li class="linkedIn-share-button">
            <a class="linkedin" title="Share this article on LinkedIn"
               href="javascript:void(0);" data-title="News%3A%202020%20Chevrolet%20Corvette%20costs%20%2459%2C995%20to%20start%2C%20including%20fees"
               onclick="hgm.trackEvent('Social Buttons Vertical', 'LinkedIn Button Clicked');popupCenter('https://www.linkedin.com/shareArticle?mini=true&amp;url=https://www.thecarconnection.com/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees&amp;title=News%3A%202020%20Chevrolet%20Corvette%20costs%20%2459%2C995%20to%20start%2C%20including%20fees', 700, 420)">
            </a>
        </li>
        <!-- TODO change this into mailto link
        <li class="email-this-button">
            <a class="email-this m-email" title="Email this article" data-subject="" href="#"></a>
        </li>
        -->
    </ul>
    <br clear="all"/>
</div> <!-- social -->
<div id="social-email-div" style="display:none">
    <div class="title"><h2>Email This Page</h2></div>
    <div id="social-error-messages"></div>
    <form id="social-email-form">
        <div><label for="social-fromname">Your Name</label><input type="text" name="fromName" id="social-fromname" class="social-form-field"></div>
        <input type="text" name="email" id="social-fake-email" class="social-form-field">
        <div><label for="social-fromemail">Your Email</label><input type="text" name="fromEmail" id="social-fromemail" class="social-form-field"></div>
        <div><label for="social-to">To <span>(separate emails with commas)</span></label><input type="text" name="to" id="social-to" class="social-form-field"></div>
        <div><label for="social-message">Message <span>(optional)</span></label><textarea name="message" id="social-message" class="social-form-field"></textarea></div>
        <input type="hidden" name="token" value="ORV1PDQpCGqdjxzoQ13Z9p7G1rqjYI4Ib2qQbSP9Jrc=">
        <div id="social-submit"><div class="btn">Send</div></div>
    </form>
    <div id="social-success-message">
        <div>Your email was sent successfully.</div>
        <div><span class="social-close">Close</span></div>
    </div>
    <br>
</div></div>
<!-- left column 685px -->
<div id="left-column">
    <div class="date">August 15, 2019</div>
    <div class="article-content">
        <p>Chevrolet on Thursday confirmed a surprise.</p>
<p>Although the automaker announced last month that the mid-engine <a href="https://www.thecarconnection.com/overview/chevrolet_corvette_2020">2020 Chevy Corvette</a> would cost less than $60,000, many expected that price would exclude the mandatory destination charge that would add another $1,000 or so.</p>
<p>Not so. When it goes on sale later this year, the 2020 Chevy Corvette will cost $59,995, including destination.</p>
<p>For that sum, buyers will get a 2020 Corvette LT1 with a 6.2-liter V-8 rated at 490 horsepower mated to an 8-speed dual-clutch automatic transmission that drives the rear wheels. Inside, it will have leather power-adjustable seats, an 8.0-inch touchscreen for infotainment with Apple CarPlay and Android Auto compatibility, a Bose 10-speed speaker audio system, a removable roof, and a 12-inch digital display.</p>
<p>The 2020 Corvette LT2 costs $67,295—up $7,300—and includes a head-up display, a wireless phone charger, heated and cooled seats, a heated steering wheel, on-board data and video recorder, blind-spot monitors, a front-facing camera, and navigation.</p>
<p>The top-of-the-line Corvette LT3 costs $71,945 and adds softer leather, suede accents, leather-wrapped doors, and carbon-fiber trim.</p>
<p>A Z51 performance package adds $5,000 to the price of any trim level and includes a performance exhaust, summer tires, sportier suspension, an electronic limited-slip differential, a front splitter, a rear spoiler, larger brakes, and better cooling for the brakes and engine. For less than $65,000, the Corvette LT1 with the Z51 package will sprint to 60 mph in less than three seconds, which means we live in exciting times.</p>
<p>Beyond the Z51, a hydraulic lift for the nose to clear speed bumps or steep driveways will add $1,495 to the bottom line.</p>
<p>The eighth-generation <a href="https://www.thecarconnection.com/news/1118230_ford-expedition-chevrolet-corvette-top-list-of-new-cars-owners-keep-the-longest">Chevy Corvette will be produced</a> at the automaker's plant in Kentucky later this year, with the first versions arriving toward the end of the year.</p>    </div>
                <div class="tags-and-cats">
            <span>Tags:</span>
            <div class="article-tags">
                                                                            <a href="/news/2020" rel="tag">2020</a>
                                            <a href="/news/corvette" rel="tag">Chevrolet Corvette News</a>
                                            <a href="/news/chevrolet" rel="tag">Chevrolet News</a>
                                            <a href="/news/coupes" rel="tag">Coupes</a>
                                            <a href="/news/news" rel="tag">News</a>
                                            <a href="/news/sport-cars" rel="tag">Sports Cars</a>
                                                    <div class="clear"></div>
            </div>
            <div class="clear"></div>
        </div><!-- tags-and-cats -->
        <div class="overview drivers-choice not-nominated">
    <span class="contest-logo"></span>
    <div class="voting">
        <div id="bctb-year">2019</div>
        <div id="title1">The Car Connection</div>
                    <a href="/driverschoice">See the winners &#187</a>
            </div>
</div>
    <div class="best-car-to-buy promo">
    <span class="contest-logo"></span>
    <div id="bctb-year">2019</div>
    <div class="contest-text">
        <div id="title1">The Car Connection</div>
        <div id="title3"><a href="/bestcartobuy/2019">See The Winner and Nominees &#187;</a></div>
    </div>
</div>

    <!-- start photo gallery -->
<div class="recommended-galleries group">
    <h3>Recommended Galleries</h3>
            <!-- start common photogallery -->
        <div class="recommended-gallery odd">
            <a class="recommended-link image" href="/news/1124544_2020-ford-ranger-fx2-is-the-baja-pickup-ready-for-cities">
                <img class="fitfill" src="https://images.hgmsites.net/med/ford-ranger_100711669_m.jpg" alt="2020 Ford Ranger FX2 is the Baja pickup ready for cities"/>            </a>
            <a href="/news/1124544_2020-ford-ranger-fx2-is-the-baja-pickup-ready-for-cities">
                <span>2020 Ford Ranger FX2 is the Baja pickup ready for cities</span>
            </a>
        </div>
        <!-- end common photogallery -->
            <!-- start common photogallery -->
        <div class="recommended-gallery even">
            <a class="recommended-link image" href="/news/1124469_2020-buick-encore-gx-to-get-turbo-3-engines-three-trims-active-safety-features">
                <img class="fitfill" src="https://images.hgmsites.net/med/buick_100702405_m.jpg" alt="2020 Buick Encore GX to get turbo-3 engines, three trims, active safety features"/>            </a>
            <a href="/news/1124469_2020-buick-encore-gx-to-get-turbo-3-engines-three-trims-active-safety-features">
                <span>2020 Buick Encore GX to get turbo-3 engines, three trims, active safety features</span>
            </a>
        </div>
        <!-- end common photogallery -->
            <!-- start common photogallery -->
        <div class="recommended-gallery odd">
            <a class="recommended-link image" href="/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees">
                <img class="fitfill" src="https://images.hgmsites.net/med/2020-chevrolet-corvette_100708581_m.jpg" alt="2020 Chevrolet Corvette costs $59,995 to start, including fees"/>            </a>
            <a href="/news/1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees">
                <span>2020 Chevrolet Corvette costs $59,995 to start, including fees</span>
            </a>
        </div>
        <!-- end common photogallery -->
            <!-- start common photogallery -->
        <div class="recommended-gallery even">
            <a class="recommended-link image" href="/news/1124504_2020-nissan-maxima-price-specs-details">
                <img class="fitfill" src="https://images.hgmsites.net/med/2020-nissan-maxima_100711302_m.jpg" alt="2020 Nissan Maxima adds active safety tech, starts at $35,100"/>            </a>
            <a href="/news/1124504_2020-nissan-maxima-price-specs-details">
                <span>2020 Nissan Maxima adds active safety tech, starts at $35,100</span>
            </a>
        </div>
        <!-- end common photogallery -->
    </div>
<!-- end photo gallery -->
<script>
    $('.recommended-galleries .recommended-link img.fitfill').imgFitFill({mode:'fill'});
    $('.recommended-gallery').click(function(){hgm.trackEvent('Recommended Gallery', 'clicked');});
</script>    <div class="bottom-center-adverts">
        <!-- GPT ADS 300x250 code begin -->
<div id="ad-5" class="ad ad-t-r" style="max-width: 300px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-5');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-5') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
            </div>
    <div id="articles-suggest">
    <h3>People who read this also read</h3>
    <ul>
                        <li class="odd" >
                            <a class="image-size" href="/news/1124166_2020-kia-telluride-is-a-top-safety-pick-but-only-with-certain-headlights" title="2020 Kia Telluride is a Top Safety Pick, but only with certain headlights">
                    <img class="fitfill" src="https://images.hgmsites.net/med/2020-kia-telluride_100696279_m.jpg" alt="2020 Kia Telluride is a Top Safety Pick, but only with certain headlights"/>                </a>
                        <h5><a href="/news/1124166_2020-kia-telluride-is-a-top-safety-pick-but-only-with-certain-headlights" title="2020 Kia Telluride is a Top Safety Pick, but only with certain headlights">2020 Kia Telluride is a Top Safety Pick, but only with...</a></h5>
            </li>
                                <li class="even" >
                            <a class="image-size" href="/news/1124079_review-update-the-2020-kia-telluride-is-how-you-change-brand-perceptions" title="Review update: The 2020 Kia Telluride is how you change brand perceptions">
                    <img class="fitfill" src="https://images.hgmsites.net/med/2020-kia-telluride_100708331_m.jpg" alt="Review update: The 2020 Kia Telluride is how you change brand perceptions"/>                </a>
                        <h5><a href="/news/1124079_review-update-the-2020-kia-telluride-is-how-you-change-brand-perceptions" title="Review update: The 2020 Kia Telluride is how you change brand perceptions">Review update: The 2020 Kia Telluride is how you change...</a></h5>
            </li>
                                <li class="odd" >
                            <a class="image-size" href="/news/1122593_2020-kia-telluride-vs-2019-kia-sorento-compare-crossover-suvs" title="2020 Kia Telluride vs. 2019 Kia Sorento: Compare Crossover SUVs">
                    <img class="fitfill" src="https://images.hgmsites.net/med/2020-kia-telluride_100696279_m.jpg" alt="2020 Kia Telluride vs. 2019 Kia Sorento: Compare Crossover SUVs"/>                </a>
                        <h5><a href="/news/1122593_2020-kia-telluride-vs-2019-kia-sorento-compare-crossover-suvs" title="2020 Kia Telluride vs. 2019 Kia Sorento: Compare Crossover SUVs">2020 Kia Telluride vs. 2019 Kia Sorento: Compare Crossover...</a></h5>
            </li>
                                <li class="even" >
                            <a class="image-size" href="/news/1122530_2019-honda-civic-vs-2020-toyota-corolla-compare-cars" title="2019 Honda Civic vs. 2020 Toyota Corolla: Compare Cars">
                    <img class="fitfill" src="https://images.hgmsites.net/med/2019-honda-civic-sdn_100677007_m.jpg" alt="2019 Honda Civic vs. 2020 Toyota Corolla: Compare Cars"/>                </a>
                        <h5><a href="/news/1122530_2019-honda-civic-vs-2020-toyota-corolla-compare-cars" title="2019 Honda Civic vs. 2020 Toyota Corolla: Compare Cars">2019 Honda Civic vs. 2020 Toyota Corolla: Compare Cars</a></h5>
            </li>
                </ul>
</div>
<script type="text/javascript">
    //<![CDATA[
    $("#articles-suggest a.image-size img.fitfill").imgFitFill({mode:'fill'});
    //]]>
</script>

    <div class="clear"></div>
    <div id="comments"> </div>
<div id="disqus_thread"> </div>
<script type="text/javascript">
    $(function () {
        $('#comments').waypoint(
            // handler
            function(direction) {
                $.getScript('/blocks/threaded-comments/disqusinit?id=1124589&type=blog');
            },
            // options
            {
                offset: '100%',
                triggerOnce: true
            }
        );
    });
</script>
    <div class="block_border">&nbsp;</div>
    <div id="contribute-followus">
        <div class="contribute">
            <div class="label">Contribute</div>
            <a class="sendUsTip" href="/contactus">Send us a tip</a>
            <a class="comments" href="#comments">Comment</a>
            <a class="contactEditor" href="/contactus">Contact the editor</a>
        </div>
        <div class="followus">
            <div class="label">Follow Us</div>
            <div class="facebook-twitter-follow">
                <div class="fb-like-btn">
    <div class="fb-like" data-href="https://www.facebook.com/TheCarConnection" data-send="false" data-layout="box_count" data-width="60" data-show-faces="false" data-colorscheme="light" ></div></div>
                <div class="twitter-btn">
                    <a href="https://twitter.com/CarConnection" class="twitter-follow-button" data-show-count="false" data-size="large"></a>                </div>
                                    <a class="youtube-btn" target="_blank" href="http://www.youtube.com/subscription_center?add_user=thecarconnection" title="Follow us on YouTube">&nbsp;</a>
                                <div class="google-plus">
                                    </div>
            </div>
        </div>
        <br clear="all" />
    </div>
</div>
<script>
    $(function() {
            });
</script>
                    </div>
        <!-- ad column 300px -->
        <div id="right-column">
            <div>
    <!-- Do not change the ids for ad blocks.  It is used for gallery ad refresh -->
    <!-- GPT ADS 300x250 code begin -->
<div id="ad-2" class="ad ad-t-r" style="max-width: 300px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-2');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-2') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
    <!-- GPT ADS 300x250 code begin -->
<div id="ad-4" class="ad ad-t-r" style="max-width: 300px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-4');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-4') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
    
<div class="user-review-sidebar-promo">
    <div class="title">Ratings and Reviews</div>
    <div class="sub-title">Rate and review your car for The Car Connection</div>
    <a class="btn" title="Review Your Car" href="/write-a-review">Review your car</a>
</div>        <div class="module" id="related-news-table">
        <div class="block-header">
            <h3 class="block-title">Related Articles</h3>
        </div>
        <ul class="block-inner articles_listing">
                                                <li>
                <a class="image-link" href="/news/1124585_2020-ram-1500-ecodiesel-pickup-trucks-priced-from-38-585">
                    <img title="2020 Ram 1500 EcoDiesel pickup trucks priced from $38,585" src="https://images.hgmsites.net/tmb/ram-1500_100703860_t.gif" alt="2020 Ram 1500 EcoDiesel" width="90" height="60"/>                                        </a>
                <a class="title-link" href="/news/1124585_2020-ram-1500-ecodiesel-pickup-trucks-priced-from-38-585">2020 Ram 1500 EcoDiesel pickup trucks priced from $38,585</a>
                <div class="clear"></div>
            </li>
                                                            <li>
                <a class="image-link" href="/news/1124592_2020-corvette-costs-less-than-60k-all-in-2020-mustang-shelby-gt500-performance-2020-e-tron-smashed-what-s-new-the-car-connection">
                    <img title="2020 Corvette costs less than $60K all-in, 2020 Mustang Shelby GT500 performance, 2020 E-tron smashed: What's New @ The Car Connection" src="https://images.hgmsites.net/tmb/2020-chevrolet-corvette_100708582_t.gif" alt="2020 Chevrolet Corvette Stingray" width="90" height="60"/>                                        </a>
                <a class="title-link" href="/news/1124592_2020-corvette-costs-less-than-60k-all-in-2020-mustang-shelby-gt500-performance-2020-e-tron-smashed-what-s-new-the-car-connection">2020 Corvette costs less than $60K all-in, 2020 Mustang Shelby GT500 performance, 2020 E-tron smashed: What's New @ The Car Connection</a>
                <div class="clear"></div>
            </li>
                                                            <li>
                <a class="image-link" href="/news/1124557_ford-backtracks-on-fiesta-focus-transmission-claims-offers-extended-warranties">
                    <img title="Ford backtracks on Fiesta, Focus transmission claims, offers extended warranties" src="https://static.hgmsites.net/images/cache/ford-focus_100457698_90x60.jpg" alt="2015 Ford Focus" width="90" height="60"/>                                        </a>
                <a class="title-link" href="/news/1124557_ford-backtracks-on-fiesta-focus-transmission-claims-offers-extended-warranties">Ford backtracks on Fiesta, Focus transmission claims, offers extended warranties</a>
                <div class="clear"></div>
            </li>
                                                            <li>
                <a class="image-link" href="/news/1124537_congress-plans-to-try-again-on-self-driving-car-legislation">
                    <img title="Congress plans to try again on self-driving car legislation" src="https://static.hgmsites.net/images/cache/waymo-self-driving-car_100663983_90x60.jpg" alt="Waymo self-driving car" width="90" height="60"/>                                        </a>
                <a class="title-link" href="/news/1124537_congress-plans-to-try-again-on-self-driving-car-legislation">Congress plans to try again on self-driving car legislation</a>
                <div class="clear"></div>
            </li>
                                                            <li>
                <a class="image-link" href="/news/1124552_2020-ford-ranger-fx2-arrives-acura-type-s-concept-is-coming-porsche-cayenne-with-a-plug-what-s-new-the-car-connection">
                    <img title="2020 Ford Ranger FX2 arrives, Acura Type S Concept is coming, Porsche Cayenne with a plug: What's New @ The Car Connection" src="https://images.hgmsites.net/tmb/ford-ranger_100711675_t.gif" alt="2020 Ford Ranger FX2" width="90" height="60"/>                                        </a>
                <a class="title-link" href="/news/1124552_2020-ford-ranger-fx2-arrives-acura-type-s-concept-is-coming-porsche-cayenne-with-a-plug-what-s-new-the-car-connection">2020 Ford Ranger FX2 arrives, Acura Type S Concept is coming, Porsche Cayenne with a plug: What's New @ The Car Connection</a>
                <div class="clear"></div>
            </li>
                                </ul>
        <br class="clear"/>
    </div>
<script type="text/javascript">
    //<![CDATA[
    $("#related-news-table img.fitfill").imgFitFill({mode:'fill'});
    //]]>
</script>
        <!-- GPT ADS 300x250 code begin -->
<div id="ad-3" class="ad ad-t-r" style="max-width: 300px; max-height: auto"
     >
                        <script>
                $(function () {
                    googletag.cmd.push(function() {
                        googletag.display('ad-3');                        for (var i = gptadslots.length; i--;) {
                             var curSlot = gptadslots[i];
                             if ( curSlot.getSlotElementId() === 'ad-3') {
                                googletag.pubads().refresh([curSlot]);
                             }
                        }                    });
                });
            </script>    </div>
    <div class="mailchimp-email-subscription">
    <div class="title">The Car Connection Daily Headlines</div>
    <form action="/blocks/mail-chimp-email-subscription/subscribeEmail" class="mailchimp-email-subscription-inner" method="post">
        <div class="form-inner">
            <label for="email">Stay up-to-date with the latest news in the car world delivered daily.</label>
            <input type="email" name="email"  class="subscription-email" placeholder="Enter email" />
            <div class="btn mailchimp-signup">Get the Newsletter</div>
            <div class="clear"></div>
        </div>
        <div class="policy">I agree to receive emails from the site. I can withdraw my consent at any time by unsubscribing.</div>
        <div class="thank-you">Thank you!  Please check your email for confirmation.</div>
        <div class="error"></div>
    </form>
</div>
</div>
        </div>
    </div>
</div>
<div id="popup-email-subscribe" style="display:none">
    <div id="popup-newsletter-header">
        <img src="/images/tcc2/mailchimp_popup_logo.png" />
    </div>
    <div class="email-subscribe-text" >
        <span class="subtext-one">Get the Web's best daily automotive newsletter!</span>
        <span class="subtext-two">We'll email you the latest automotive news every day.</span>
    </div>
    <form method="post" id="popup-subscription-form" action="/blocks/mail-chimp-email-subscription/subscribeEmail">
        <input type="text" onblur="if(this.value == '') { this.value = 'Enter your email address'; }"
	       onfocus="if(this.value =='Enter your email address') { this.value = ''; }"
	       class="email-fld" value="Enter your email address" name="email"
	       >
        <div id="footer-signup" class="mailchimp-signup btn">Subscribe</div>
    </form>
    <p class="thanks-msg"></p>
    <p class="msg"></p>
	<span class="error-msg"></span>
</div>

<script>
    $(function() {
        hgm.pingView(1124589, "30010445");
    });
</script>
            <div id="tcc3-footer" class="clear">
    <div class="footer-column">
        <ul class="footer-ul first">
            <li><a href="/new-cars">New Cars</a></li>
            <li><a href="/car-compare">Compare cars</a></li>
            <li><a href="/inventory/carsforsale">Cars For Sale</a></li>
            <li><a href="/inventory/trucks-for-sale">Trucks For Sale</a></li>
            <li><a href="/used-cars">Used Cars</a></li>
            <li><a href="/inventory/cheap-cars">Cheap Cars</a></li>
            <li><a href="/car-loans">Finance</a></li>
            <li><a href="/videos">Videos</a></li>
            <li><a href="/news">News</a></li>
            <li><a href="/tips">Advice</a></li>
        </ul>
        <ul class="footer-ul">
            <li><a href="/resources/">Resource Center</a></li>
            <li><a href="/aboutus">About Us</a></li>
            <li><a href="/how-we-rate">How We Rate Cars</a></li>
            <li><a href="https://connect.carsdirect.com" target="_blank">Buy Auto Leads</a></li>
            <li><a href="/contactus">Contact Us</a></li>
            <li><a href="https://www.internetbrands.com/privacy/privacy-highlights.html?site=internetbrandsauto.com">Privacy Policy</a></li>
            <li><a href="https://www.internetbrands.com/ibterms/">Legal</a></li>
            <li><a href="https://www.internetbrands.com/ibterms/supplementalcarrelatedterms/">Disclaimer</a></li>
        </ul>
       <!-- <ul class="footer-ul">
            <li><a href="/aboutus/press">Blog</a></li>
            <li><a href="/rss">RSS Feed</a></li>
            <li><a href="https://wrightsmedia.com/reprints/index.cfm?magid=3531" title="Reprints" target="_blank" rel="nofollow">Reprints</a></li>
        </ul> -->
    </div>

    <div id="footer-social-wrapper">
    <div id="footer-social-links">
        <div class="social-icons">
                            <a class="facebook" href="https://www.facebook.com/TheCarConnection" target="_blank"></a>
                                        <a class="twitter" href="https://www.twitter.com/CarConnection" target="_blank"></a>
                                                    <a class="instagram" href="https://www.instagram.com/thecarconnection/" target="_blank"></a>
                                        <a class="youtube" href="https://www.youtube.com/user/thecarconnection" target="_blank"></a>
            
            <a class="rss" href="/rss"><img src="/images/rss-icon-small.png"></a>
        </div>
    </div>
    <div class="clear"></div>
</div>
    <div class="footer-mobile"></div>
</div>
<div id="footer-copyright">
    <div>&copy; 2019 MH Sub I, LLC. 

All Rights Reserved.
Stock photography by <a href="//www.izmocars.com/">izmostock</a>.

Read our <a href="//www.internetbrands.com/privacy/cookie-policy.html">Cookie Policy</a>.

<!-- CrazyEgg -->
<script type="text/javascript">
setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//script.crazyegg.com/pages/scripts/0010/6069.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);
</script>

<script type="text/javascript">
    (function() {
        function async_load(script_url){
            var protocol = ('https:' == document.location.protocol ? 'https://' : 'http://');
            var s = document.createElement('script'); s.src = protocol + script_url;
            var x = document.getElementsByTagName('script')[0]; x.parentNode.insertBefore(s, x);
        }
        bm_website_code = '2AB7FC001C0140A3';
        jQuery(document).ready(function(){async_load('asset.pagefair.com/measure.min.js')});
        jQuery(document).ready(function(){async_load('asset.pagefair.net/ads.min.js')});
    })();
</script>
</div>
</div>

<script>
    $('.FooterMoreColumn .image-link img.fitfill').imgFitFill({mode:'fill'});
    $(hgm.addMobileSiteButton);
    $(document).ready(function() {
        // executes when HTML-Document is loaded and DOM is ready
        hgm.debug("READY = " + (new Date().getTime() - window.startTime) / 1000 + " sec");
    });

    $(window).load(function() {
        // executes when complete page is fully loaded, including all frames, objects and images
        hgm.debug("LOAD  =  " + (new Date().getTime() - window.startTime) / 1000 + " sec");
        setTimeout(function(){
            var t = performance.timing;
            hgm.debug("LOAD With Navigation Timing API = " + (t.loadEventEnd - t.navigationStart) / 1000 + " sec");
        }, 0);
    });
</script>
                    </div><!-- global-container -->
    </div>
    <!-- HGM scripts -->
<script type="text/javascript">
    

    $(function () {
        var $gallery = $('.swipe-gallery .gallery'),
            controller = $gallery.data('controller') || 'ArticleGallery';
        new hgm.photo[controller]($gallery
            , $('.swipe-gallery .thumbnails')        );
    });
    
</script>
<script type="text/javascript">
    

    if ($.browser.msie && $.browser.version === "7.0") {
        var ie_box = "<div class='ie6_message_wrapper'>    \n\
        <div class='ie6_message'>  <h3>You are using an old browser which this site does not support, please upgrade to a modern browser.</h3>\n\
        <a href='https://www.mozilla.com/en-US/firefox/new/' class='firefox'></a> \n\
        <a href='https://www.apple.com/safari/' class='safari'></a>\n\
        <a href='https://www.microsoft.com/windows/internet-explorer/default.aspx' class='explorer'></a>\n\
        <a href='https://www.opera.com/browser/' class='opera'></a>\n\<a href='https://www.google.com/chrome/index.html' class='chrome'></a>\n\
        </div></div>";
        $("body").prepend(ie_box);
    }
    
</script>
<script type="text/javascript">
    

    (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-XVB7W');
    
</script>
<script type="text/javascript" src="/js_cache/555548.js"></script><!-- HGM scripts end -->
<script type="text/javascript">
var _sf_startpt = window._sf_startpt || (new Date()).getTime();
var _sf_async_config={uid:22002,domain:"thecarconnection.com"};
_sf_async_config.authors = 'Aaron Cole';
_sf_async_config.sections = 'news';
(function() {
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('async', 'true');
    e.setAttribute('src', (("https:" == document.location.protocol) ? "https://a248.e.akamai.net/chartbeat.download.akamai.com/102508/" : "http://static.chartbeat.com/") + "js/chartbeat.js");
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();
</script>
<script>
    dataLayer.push({'exelate_query':'p=258&g=78&j=0&make=chevrolet&model=corvette&carmodelyear=2020&newcar=1&pageurl=%2Fnews%2F1124589_2020-chevrolet-corvette-costs-59995-to-start-including-fees&sitename=thecarconnection&tag1=coupes&tag2=2020&tag3=corvette&tag4=chevrolet&tag5=news&tag6=sport-cars'});
</script>
<!-- Misc ad campaigns not needing physical space -->

<!-- Tmplt: 77563 | Site: 77563 | 10.16.88.242 -->
    <!-- Nativo -->
<!-- Nativo end -->
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"fcb635eb66","applicationID":"135926741","transactionName":"MgcAYUMDDUFWAkJaDAtNI1ZFCwxcGBFXVAYWTQBZXgVOQlgSQh4CFxYLVl0HTFtZBVNL","queueTime":0,"applicationTime":328,"atts":"HkAXFwsZHh4VABQJGBgf","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>
